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This manual provides general and specific maintenance procedures essential for reliable engine operation and 
your safety. Since many variations in procedures, tools, and service parts are involved, advice for all possible 
safety conditions and hazards cannot be stated.

Read safety instructions before doing any service and test procedures for the engine or vehicle. See related 
application manuals for more information.

Obey Safety Instructions, Warnings, Cautions, and Notes in this manual. Not following Warnings, Cautions, and 
Notes can lead to injury, death, or damage to the engine or vehicle.

Safety Terminology
Terms are used to stress your safety and safe operation of the engine: Warning, Caution, and Note.

Warning: A warning describes actions necessary to prevent or eliminate conditions, hazards, and unsafe practices 
that can cause personal injury.

Caution: A caution describes actions necessary to prevent or eliminate conditions that can cause damage to the 
engine or vehicle.

Note: A note describes actions necessary for correct, efficient operation.

Work Area

•	 Keep work area clean, dry, and organized.

•	 Keep tools and parts off the floor.

•	 Make sure the work area is ventilated and well lit.

•	 Make sure a First Aid Kit is available.

Protective Measures

•	 Wear protective safety glasses and shoes.

•	 Wear correct hearing protection.

•	 Wear cotton work clothing.

•	 Wear sleeved, heat protective gloves.

•	 Do not wear rings, watches, or other jewelry.

•	 Restrain long hair.

Vehicle

•	 Shift transmission to neutral, set parking brake, and block wheels before doing diagnostic or service 
procedures.

•	 Clear the area before starting the engine.

Safety Equipment

•	 Use correct lifting devices.

•	 Use wheel chocks and stands.
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Engine

•	 The engine should be operated or serviced only by qualified individuals.

•	 Provide necessary ventilation when operating engine in a closed area.

•	 Keep combustible material away from engine exhaust system and exhaust manifolds.

•	 Install all shields, guards, and access covers before operating engine.

•	 Do not run engine with unprotected air inlets or exhaust openings. If unavoidable for service reasons, put 
protective screens over all openings before servicing engine.

•	 Shut engine off and relieve all pressure in the system before removing panels, housing covers, and caps.

•	 If an engine is not safe to operate, tag the engine and ignition key.

Fire Prevention

•	 Make sure charged fire extinguishers are in the work area.

NOTE: Check the classification of each fire extinguisher to make sure that the following fire types can be 
extinguished:

1.	 Type A – Wood, paper, textiles, and rubbish

2.	 Type B – Flammable liquids

3.	 Type C – Electrical equipment

Batteries

•	 Always disconnect the main negative battery cable first.

•	 Always connect the main negative battery cable last.

•	 Avoid leaning over batteries.

•	 Protect your eyes.

•	 Do not expose batteries to flames or sparks.

•	 Do not smoke in workplace.
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MWM SERVICE TOOL
NOTE: This section contains a brief overview of MWM SERVICE TOOL software and was current at the 
time of publishing. Due to the automatic update function in MWM SERVICE TOOL software, screens and 
functions may differ from this manual.

INTRODUCTION
MWM Service Tool is a diagnostic and programming service tool for MWM diesel engines. A fully-featured PC 
application. Coverage includes all J-1939 International® electronic engine systems, allowing you to run special 
tests, change parameters and view and graph engine data. This is the top-of-the-line tool for dealers and fleets. 
The application updates periodically, enabling you to have the most up-to-date coverage.

NOTE: To diagnose specific electronic control system failures, always refer to the diagnostic manual for 
the system being serviced.

Software Capabilities

•	 View, Snapshot Recording, Save, Playing

•	 Diagnostic Trouble Codes, View, Clear

•	 Freeze Frame Data

•	 Cylinder Cutout Test

•	 High Pressure Pump Test

•	 Programmable Parameters

•	 Read, Write Programmable Parameters
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ACRONYMS
Following is a list of acronyms and their meanings used in this document: 

DTC
	 Diagnostic Trouble Code 
DCU
	 Electronic Control Module
ECM (ECU)
	 Electronic Control Module 
ESN
	 Engine Serial Number 
EST
	 Electronic Service Tool 
FMI
	 Failure Mode Indicator 
SPN
	 Suspect Parameter Number 
MIN
	 Minimum 
MAX
	 Maximum
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GETTING STARTED

SYSTEM REQUIREMENTS

Minimum Requirements

•	 Microsoft® Windows® Vista, Windows 7, or Windows 10 64-bit

•	 1 GHz Intel Core 2 Duo, AMD Athlon X2 or better

•	 2GB (32-bit) or 4GB (64-bit) of RAM

•	 300 MB of free hard disk space

•	 High speed Internet connection needed for software updates

•	 1024 x 768 pixel (or better) display

•	 One or more RP1210A compatible communication devices with SAE J1708 and / or SAE J1939 support  
(See Diagnostic Interface Cable Information, page 13)

Improved system performance will occur with the installation of increased RAM.

Communication Link Drivers

•	 MWM Service Tool uses standard RP1210A drivers for communication. The drivers are specific to the 
communications device and are not installed with MWM Service Tool.
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INSTALLING THE MWM SERVICE TOOL SOFTWARE
It is strongly recommended that all Terminate and Stay Resident (TSR) programs like the Quicktime® program, 
CD player programs, or Pocket PC programs be terminated prior to loading or starting the MWM Service Tool 
software. These programs interfere with the efficient operation of the MWM Service Tool.

To install the MWM Service Tool software:

1.	 Prior to installation, a MWM Service Tool product key must be obtained for each computer on which the 
software is to be installed. Product keys expire after a year and must reactivated to allow access to the 
program.

2.	 Using the web browser of your choice, navigate to the MWM Service Tool page on the Navistar Service 
Software site:

	 https://www.navistarservicesoftware.com/index.php/mwm/

3.	 Select the DOWNLOAD button to download the MWM Service Tool software.

4.	 When the file has finished downloading, run it (MWM Service Tool Setup.exe) to begin installation.  
The first page of the Setup Wizard appears.

Figure 1 - Setup Wizard: Welcome

5.	 Click NEXT.
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Figure 2 - Setup Wizard: License Agreement

6.	 Read through the License Agreement. When finished, click I AGREE to proceed with installation.  
When installation is complete, the final page of the wizard is displayed.
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Figure 3 - Setup Wizard: Finish

7.	 Ensure that the RUN MWM SERVICE TOOL box is checked.

8.	 Click FINISH to launch the program.

	 The first time MWM SERVICE TOOL is installed on a specific computer, you will be prompted to enter your 
product key.
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9.	 Enter the product key obtained for this computer and then click OK.

•	 If the key was not entered correctly (or there is some other problem), an error message will be displayed. 
Refer to Installation Error Messages (page 11) for more information. Resolve the issue indicated before 
proceeding.

•	 If the key was entered correctly, the following window is displayed. Proceed to Step 11.

Figure 4 - Product Key Entry

Figure 5 - Existing User Prompt
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10.	 If you already have a Navistar-issued username and password for applications such as Diamond Logic® 

Builder (DLB), NavKal™ or Navistar Engine Diagnostics, click YES and proceed to Step 15.
	 If you DO NOT already have a Navistar issued username and password, click NO and proceed to Step 12.

11.	 The Registration window appears. Fill in the information in this window. Required fields are indicated by an 
asterisk (*).

12.	 Click OK.
	 Once registration is completed successfully, the following message is displayed:

Figure 6 - New User Registration

Figure 7 - Username Successfully Created
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13.	 An email will be sent to the address provided on the registration form. Follow the instructions provided in this 
email to complete the registration process. When finished, click OK in the window shown above.

NOTE: You MUST change your password by following the instructions provided in the email before 
proceeding. The default password cannot be used to log into the application.

14.	 The User Authentication window appears. Enter your username and password and click OK.

Figure 8 - User Authentication Window

Once you are logged in for the first time, the software will start and begin to update itself.

NOTE: The MWM Service Tool program will not function until you have successfully logged in at least 
once while connected to the network. You may need to consult with the technical computer support staff 
if the MWM Service Tool program cannot connect to the Navistar site. Error messages will be generated if 
connection to Navistar fails. Your Internet firewalls must be configured to allow two-way communication 
to the following Navistar host names:

•	 *.navistar.com

•	 *.internationaldelivers.com

•	 *.amazonaws.com

•	 *.cloudfront.net

Be aware that the underlying IP addresses for these hosts are subject to change and may vary by region. 
When possible, grant access by host name rather than IP address.
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Installation Error Messages
The error messages that may appear during the installation process typically contain explanatory text to help  in 
troubleshooting. Some sample messages are shown in the table below. In some cases, the table also includes 
additional troubleshooting information. For the more information on resolving these messages, please visit the 
MWM Service Tool support website:

http://www.navistarservicesoftware.com

NOTE: Before attempting to register the software with a product key, please ensure that you have an 
active User ID with a password that has not expired.

Code Text
800 The product key provided is terminated. Please visit the support page for assistance.
801 The product key provided does not match the software that you are attempting to activate. Please 

re-enter the product key to verify or visit the MWM Service Tool support page for assistance.
802 Your product key has expired. Please visit the support page for assistance.
803 You’ve exceeded the number of registrations allowed for this product. Please visit the MWM Service 

Tool support page for assistance.
804 An unknown error has occurred. Please visit the support page for assistance.
805 Application unsupported. Please visit the support page for assistance.
806 The prior product key provided is terminated. Please visit the support page for assistance.
807 The product key provided was not found. Please re-enter the product key to verify or visit the support 

page for assistance.
808 An error has occurred while attempting to register the software. Please visit the support page for 

assistance.
809 We’re sorry, we can’t connect to the server right now. Please check your connection and try again or 

visit the support page for assistance.
810 An Internet connection to the MWM Service Tool server could not be established; press OK to 

continue in offline mode. Your license will be verified each time you log into the system. You can 
keep accessing MWM Service Tool offline for 30 remaining days. If a connection to the MWM Service 
Tool Server cannot be established by then, your product will stop working.
Verify that the following Navistar hosts are not blocked by a firewall or a web filter:
•	 *.navistar.com
•	 *.internationaldelivers.com
•	 *.amazonaws.com
•	 *.cloudfront.net

811 An Internet connection to the server could not be established, you must resolve this issue before the 
application can be used.

This error occurs when the license key has expired due to being offline for 30 days or more.
812 An Internet connection to the server could not be established, you must resolve this issue before the 

application can be used.

On some computers, MWM Service Tool has to be run in administrator mode. Follow these steps:

1.	 On the Windows desktop, right-click the MWM Service Tool icon.

2.	 In the right-click menu, select OPEN FILE LOCATION.

3.	 Right-click MWM Service Tool.

4.	 Select RUN AS ADMIN.
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Code Text
813 Please enter your product key. If you do not have a product key, please visit the support page for 

assistance.

The entered product key was not correct. Be sure to include the entire key. Which has be 19 
characters total, not including dashes.

814 You have already activated your maximum number of Usernames permitted by your license.
815 A server side error has occurred and is being examined. Please visit the support page for assistance.
816 The provided key is a renewal key. Please re-enter a previous product key to continue or visit the 

support page for assistance.

Renewal keys allow the license granted by a full key to the software to be extended past its original 
expiration date. They cannot be used by themselves (without a full product key). Enter the full 
product key whose expiration date is to be extended.

817 The Username or Password that you entered was incorrect. Please try again or visit the support 
page for assistance.
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DIAGNOSTIC INTERFACE CABLE INFORMATION
The following communication adapters have been verified with all MWM SERVICE TOOL software:

•	 Dearborn Group Technologies – DPA 5

•	 NEXIQ Technologies – USB-LinkTM 1 and USB-LinkTM 2

•	 Noregon Systems, Inc. – DLA, DLA USB

Other RP1210A compliant interface devices may work with MWM SERVICE TOOL.

Please refer to each manufacturer’s website for further information.
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USER INTERFACE

LAUNCHING MWM SERVICE TOOL

To Launch MWM SERVICE TOOL:
1.	 Start the application. There are three ways to do this:

•	 Double-click the MWM Service Tool icon on your desktop.

•	 Right-click on the MWM Service Tool icon on your desktop. Then, select OPEN.

•	 From the Windows Start menu, select Programs > MWM Service Tool > MW< Service Tool.

2.	 The User Authentication window appears. Enter your username and password and click OK.

Figure 9 - MWM Service Tool Icon

Figure 10 - User Authentication Window
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DEFAULT SESSION VIEW
When MWM Service Tool is started, a Default session displays as the opening screen. The following is a brief 
description of each area displayed in the Default session.

Figure 11 - Panes in Default Session View
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2.	 Default Session Overview
The default session contains a number of tabs that display information about the engine that is currently 
connected or being simulated. One of these tabs is the Connection tab.
•	 Connection tab: Provides information about engine auto-detection, viewing and clearing DTCs 

(Diagnostic Trouble Codes), and supported engines. Displays module activity on the public CAN network.

3.	 Diagnostic Trouble Code (DTC) Panel
The DTC Panel allows you to view, clear and request freeze frame data. The REFRESH button sends a  
DTC request for update. The SHOW ALL MODULES button displays DTCs for all modules (rather than just 
the ECM).

1. 	 Vehicle Information Pane
The Vehicle Information pane provides vehicle information for the connected vehicle, such as:
•	 Engine Type

•	 Software Identification

•	 Factory Data

•	 Vehicle Identification Number

•	 Engine Serial Number

•	 Rated Power

•	 ECU Hardware Number

•	 ECU Software Version

•	 DataSet Identification

•	 DCU Hardware Number

•	 DCU Software Version
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CONNECTION
Connection Procedure
1.	 Open and log into the MWM Service Tool software.

2.	 Using interface cable, connect Electronic Service Tool (EST) to vehicle diagnostic connector.

Figure 12 - Manual Cable Type Selection

Figure 13 - COM Link Button

Figure 14 - Communication Indicator

3.	 If the interface cable is not automatically selected by the software, select Connection > Select COM Link 
then select the interface cable from the options listed.

4.	 Key ON, Engine OFF.

5.	 If the COM Link button does not indicate that the ECM is being probed, click COM Link button to probe and 
connect to engine.

6.	 The communication indicator in the lower right corner of the window will indicate when the communication link 
has been established.

7.	 The software will start probing for a supported engine calibration ID. The displayed Engine Type and available 
features vary based on whether the engine is supported.

Probing ECM Connected

Not Connected Connected
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QUICK ACCESS BAR

Item Icon Description

1 COM Link: Turns communication to the ECM on and off.

2 Trigger Arm / Disarm: Enables or disables triggered recording. (See 
Shapshots: Trigger Setup, page 40).

3
Record Session Signals: Starts a snapshot recording of signals within 
the current session. Click again to stop recording.(See Snapshots: 
Starting a Recording, page 38).

4
Default Session: Loads the Default session view, which monitors all 
position, temperature, and pressure sensors. (See Default Session 
View, page 15).

5
Programming Session: Loads the Programming session view, which 
displays all programmable parameters. (See Viewing Parameters, 
page 44).

6
Signals Session: Loads the Signals session view, which displays 
all signals available for the connected engine monitors specific and 
allows you to select which signals to watch and record.

7 Stop Tests: This will abort / stop any test or procedure that is currently 
running. 

Figure 15 - Quick Access Bar Icons
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THE MENU BAR

Figure 17 - Menu Bar
1.	 Menu Bar

Item Description
Open Folder Opens the folder in which Snapshots are stored. This allows easy copying and 

pasting saved files into case reports.
Reports View, export, print, or reset a report. There are three reports available.

•	 Full Vehicle Report: includes vehicle information, signals, parameters, and 
signals, and DTCs with freeze frame data.

•	 Activity Trip Route: includes driver activity, average speed, acceleration, 
braking, etc. The route also provides Print and Reset Trip functions.

•	 Event Data Recorder: records data on vehicle normal and hard acceleration 
and deceleration events.

Exit Close the MWM Service Tool software.

The menu bar (Figure 17, Item 1) contains a row of menu icons. Select a menu icons to display the options in that 
menu. Selecting an individual option allows you to perform a task within the software.

File Menu
The File menu is used to access files and reports and to create and edit engine templates.



USER 21

MWM Service Tool - Customer

Item Description
Activate COM Link Start (or stop) communicating with the ECM.
Select COM Link Manually select the type of interface cable used to connect to the vehicle.

Connection Menu
The Connection menu provides connection choices, including selecting the type of interface cable, selecting the 
connected engine, and simulating a non-connected engine.

Item Description
Default Default session view, which monitors all position, temperature, and pressure 

sensors. (See Default Session View, page 15).
Programming Programming session view, which displays several tabs that contain 

programmable parameters.
Signals Signals session view, which monitors specific signals.
Flashing Flashing session view, which evaluates the calibration software version.

Sessions Menu
Selecting the name of a predefined session in this menu displays the panels that are included in that predefined 
session.

Item Description
To open Test Session
Cylinder Cutout Test
High Pressure Test

Tests Menu
The Tests menu displays a list of tests that can be initiated for the connected engine. If no engine is connected or 
no tests are available for the connected engine, this menu will not appear.

Item Description
Start / Stop Recording Starts recording the signals selected for the current session. Select this option 

again to stop recording. (See Snapshots: Starting a Recording, page 38).
Set Data Sample Rate Sets the data sampling rate for recorded sessions. Longer recordings can be 

made by slowing the sample rate.
Trigger Setup Opens the Snapshot Trigger Setup window. This window is used to specify 

the conditions (if any) that trigger automatic recording of session data. (See 
Shapshots: Trigger Setup, page 40).

Arm Trigger If a trigger has been configured in the Snapshot Trigger Setup window, select 
this option to enable or disable triggered recording. (See Shapshots: Trigger 
Setup, page 40).

Playback Snapshot 
Recording

Allows you to open, view, print and playback previously recorded snapshots in 
text or graph view. (See SnapShot: Playback, page 42).

Snapshot Menu



22 USER

MWM Service Tool - Customer

Item Description
Display Metric Units of 
Measure

Check the first item in this menu to display metric values in MWM Service Tool. 
Uncheck this item to display English measures.

Clear Statistics Reset the minimum, maximum and average values for all signals in the current 
session.

Session Tools This sub-menu contains all the session editing tools, including create, add 
content, rename, and load previously saved.
•	 Create Session: Opens a basic default session with a Signals panel and a 

DTC list.
•	 Save Session: Saves the current session. (See Saving Session Files, page 

36).
•	 Load Session: Loads a previously saved session (See Loading a Saved 

Session, page 37).
•	 Rename Session: Allows the current session to be renamed. This is useful 

for identifying what session a particular snapshot is taken from.
•	 Session Register: 
•	 Recommended Views:
•	 Test Specific Views:
•	 Information About the Vehicle
•	 Instructions
•	 Signals
•	 Parameter
•	 Detector
•	 Diagnostic troubles code

Tools Menu
The Tools menu contains a collection of helpful functions.
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Item Description
About Displays version information. (See About MWM Service Tool, page 29).
Messages Displays messages received from MWM. (See Messages from MWM, page 28).
DataBase Displays information about DataBase.
Registration Displays registration information for this installation of the software and other 

computers that use the same product key.

If you have a multi-user license for this software, the first user to install the 
software with your product key becomes the administrator for the individual user 
licenses. Some items on this menu are visible only to the administrator.

License Agreement Displays end user license agreements for MWM Service Tool and its com-
ponents.

View Log Displays the data log. If you contact Navistar support, they may ask you to send 
them a copy of this log.

Detailed Logging Select this item to enable detailed logging. (A check appears next to this item 
when detailed logging is enabled.) Select this item again to disable detailed 
logging.

Help Menu
The Help menu displays detailed information about the MWM Service Tool software.
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STATUS BAR

1.	 Tool Version
	 Software version number. More version details are displayed in the HELP > ABOUT window.

2.	 Activity
	 Shows communication between the software and the connected module.

3.	 ECM Connection Status Icon
	 Show connection status between the ECM and the EST.

•	 No Communication: icon is BLACK and separated.
•	 Communication: icon is GREEN and joined.

Figure 18 - Status Bar
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MESSAGES FROM NAVISTAR

Figure 19 - Messages from Navistar

After an update, a Messages from Navistar window (Figure 19) will pop up to display important messages about 
the updated version.

Suppressing the Display of Previously-Viewed Messages
To disable a message and prevent it from being displayed in the future, check the box in the Hide column of the 
message to be disabled.

Viewing Past Messages
To view past messages, select HELP > MESSAGES in the menu bar.
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ABOUT MWM SERVICE TOOL

The About MWM Service Tool window displays information about the current version of the MWM Service Tool 
software.

To open this window:

•	 Select HELP > ABOUT in the menu bar.

Viewing the Change Log
The change log contains information about the updated content in each version release. To view the change log:

•	 Click the CHANGE LOG button in the About MWM Service Tool window.

Figure 20 - About MWM Service Tool Window
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DIAGNOSTIC TROUBLE CODES

THE DTC PANEL
The Diagnostic Trouble Code (DTC) panel is able to read and clear DTCs from many different modules, as long 
as they are connected to the Public CAN Network and follow SAE specifications.

1.	 Diagnostic Trouble Code (DTC) column (pre-
2010)

2.	 Suspect Parameter Number (SPN) column

3.	 Failure Mode Indicator (FMI) column

4.	 Type column (Active / Previously Active / Pending)

5.	 Show All Modules button 

6.	 Clear DTCs button 

Figure 21 - DTC Panel

DTC IDENTIFICATION
DTC identification is accomplished using two fault code identifiers. These two identifiers, known as the SPN and 
the FMI, are displayed in the DTC Panel.

Identifier Type Description
Suspect Parameter Number (SPN) SPN identifies the component or system in which the fault occurs.
Failure Mode Indicator (FMI) FMI identifies the type of fault.
Diagnostic Trouble Code (DTC) DTC was a unique number that loosely identified SPN / FMI in older (Pre-

2010) engines.
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DTC TYPE

DTC Type Description
Active •	 A single trip fault has been detected on the current drive cycle.

•	 A two trip fault has been detected on two consecutive drive cycles. 
(Two trip faults must be detected more than once to be considered 
Active).

•	 2016 and later models: This status also includes faults that were 
detected up to three drive cycles ago.

Previously Active Inactive faults that were active at least four, but not more than forty, drive 
cycles ago.

Healing This status indicates a fault that was active one to three drive cycles ago, 
but has not been detected on the current drive cycle.

This status is used only for Euro V engines.
Pending A two trip fault that occurred in one drive cycle. Such faults become 

Active if they are detected again on the following drive cycle.

This status is used only for Euro V engines.
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CLEARING DTCS
When Only ECM Faults are Displayed

1.	 Key ON, Engine OFF.

2.	 Click CLEAR DTCS.

When All Modules are Displayed

Figure 23 - Clear Faults Window

1.	 Key ON, Engine OFF.

2.	 Click CLEAR DTCS.

3.	 Select the module(s) whose faults you want to clear.

4.	 Click OK.
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SESSIONS
A session specifies which panels and tabs are displayed in the user interface. There are many different types of 
session, each of which provides information and controls for a particular task.

SESSIONS MENU
Select any item in the Sessions menu to load a predefined session. (See Sessions Menu, page 30).
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BUILDING A CUSTOM SESSION
Users can build their own sessions to monitor specific parameters or signals not usually grouped together.

1.	 Signal graph display pane

2.	 Show Watched / Show All button

3.	 Watched column boxes

4.	 Graph legend

5.	 Signal list

Figure 24 - Signals Session

1.	 In the menu bar, select Tools > Session Tools > Create Session.

2.	 Select desired signals by checking the boxes in the Watched column.

3.	 Once all desired signals have been selected, click Show Watched to hide all signals that were not selected. 

To show all signals again, click the Show All button.

NOTE: The list may be scrolled up and down using the window scroll bar.

NOTE: Displayed signals are represented by different colored graph lines. When multiple signals 
are displayed, signal identification can be made using the graph legend. Check the box in the 
Watched column to show the graph for a desired signal. Uncheck the box to hide that signal’s 
graph.
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SESSION DETAILS
Users can change which columns are displayed in the signal list, add tabs containing other information, and 
configure or rename the Sessions tab.

Adding and Removing Columns
1.	 Right-click on the title bar at the top of the signal list. The right-click menu for the list appears.

2.	 Check the box next to a listed item to add that information to the table. Each checked item will be displayed 
as a column in the signal list.

NOTE: A column can be moved by clicking the column header and dragging to the left or right.  

Adding Tabs to the Session
Other tabs can be added to a session by selecting any item in the lower portion of the Tools > Session Tools 
sub-menu.

To move a tab to another pane, click the name of the tab and drag it into the desired pane.

Configuring and Renaming the Sessions Tab

Figure 25 - Signals Right-Click Menu

Right-clicking on the name of the signals tab produces a menu that allows the tab to be configured. The options 
listed here include:

•	 Close: Close the Signals tab.

•	 Rename Tab: Change the name of the Signals tab.

•	 Show Show Watched Button: Show or hide the Show Watched / Show All button.

•	 Show Graph: Show or hide the signals graph.

•	 Show Table: Show or hide the signal list.

•	 Show Description: Show or hide the description.

•	 Show Watched Only: Same function as Show Watched / Show All button.
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SAVING SESSION FILES

Figure 26 - Saving a Session File

Built or modified session files can be saved to be loaded at a later time. This does not affect any of the software’s 
premade sessions.

1.	 In the menu bar, select Tools > Session Tools > Save Session.

2.	 Navigate to the folder in which you wish to save the session file.

3.	 Type the desired session name in the File name box.

4.	 Click SAVE.
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LOADING A SAVED SESSION
1.	 In the menu bar, select Tools > Session Tools > Load Session.

Figure 27 - Opening a Saved Session

2.	 Select the session file to be opened.

3.	 Click OPEN.
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SNAPSHOTS: STARTING A RECORDING
Snapshot recordings capture a large amount of data for later analysis.

Figure 28 - Recording Interval Selection

Figure 29 - Record Buttons

Using the Recording Interval scale, you can adjust the amount of data being recorded in a snapshot. The default 
setting is 0.2 seconds.

Record Session Record All

Figure 30 - Record Stop Button

1.	 Click one of the RECORD buttons in the quick access bar to start a snapshot recording:

•	 Record Session: for most common signal recording needs.

•	 Record All: used to record all signals to find uncommon issues

NOTE: When the recording function is active, the record buttons display a Stop sign.
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2.	 Click the Record Stop button to stop recording.

3.	 When recording is stopped, a pop up message alerts you to the name of the file and the location to which it 
was saved.
The default save location is the SnapShots folder on the Windows desktop. 
Snapshot names will include the following information:
•	 Session Name

•	 Time Stamp (YYYY_MM_DD_MM_SS_SSS)

•	 Language

•	 File Type

Figure 31 - Recording Saved Window
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SHAPSHOTS: TRIGGER SETUP
A trigger is a user-specified event that will start snapshot recording automatically. This is helpful in capturing the 
data generated at the moment the trigger event occurs.

Setting Up a Triggered Recording
1.	 In the menu bar, select Snapshot > Trigger Setup.

Figure 32 - Snapshot Trigger Setup

2.	 In the Signal column, select a signal to monitor.

3.	 In the Logic column, specify whether the signal value must be greater than, less than, equal to, or not equal 
to the trigger value.

4.	 In the Value and Unit columns, specify the trigger value.

5.	 If more than one signal will serve as a trigger, click the ADD CRITERIA button and repeat Steps 2 to 4 for 
each desired signal.

6.	 If you want recording to begin before the trigger event occurs, enter the number of seconds to record before 
the trigger event in the Record Pre-Trigger box.

7.	 In the Post-Trigger box, enter the number of seconds to record after the trigger value is met.

8.	 If recording should occur every time the trigger value is met, check the Recurring Trigger box. Leave the box 
unchecked to record only the first occurrence.
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10.	 To arm the trigger, click the Trigger Arm / Disarm button in the Quick Access Bar.

9.	 Click SAVE.

NOTE: The saved trigger only applies to the current session. (Trigger setup will be lost if the 
session is changed.)

Figure 33 - Trigger Arm / Disarm Button
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SNAPSHOT: PLAYBACK
1.	 In the menu bar, select Snapshot > Playback Snapshot Recording.

Figure 34 - Opening a Snapshot File
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2.	 Select a previously recorded file.

3.	 Click OPEN.

4.	 In the Graph column, put a check next to the signals you wish to view.

Figure 35 - Recorded Signal Playback
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PARAMETERS
Engine parameters can be used:

•	 to configure the engine to chassis interface

•	 to add or remove features

•	 to reset accumulators for trip route and parts replacements

•	 to configure customer-programmable preferences

VIEWING PARAMETERS

1.	 Programming Session button 2.	 All Parameters tab

•	 In the menu bar, select Session > Programming.

The Programming session is divided into sub-system tabs to help find desired parameters quickly. Alternately, 
view all parameters available for the connected engine by selecting the All Parameters tab (Figure 36 Item 2).

Figure 36 - Viewing Parameters
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SEARCHING FOR A PARAMETER

Figure 38 - Parameter Search Controls

1.	 Select the All Parameters tab (Figure 38, Item 2).
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Figure 39 - Parameter Group List

3.	 Select a group to search for or enter a search keyword.

4.	 Click OK. Parameters that match will be brought to the top of the list

NOTE: To clear the search and return the list to its original order, click the filter icon and then 
click Clear.
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PROGRAMMING

1.	 Undo All Changes Button

2.	 Value Column

3.	 Program Engine Button

4.	 Undo Button

Figure 40 - Programming Interface

1.	 Click the Value column for the parameter to be changed.

2.	 Specify the desired value. Some fields allow direct entry of the value, some require that you select a value 
from a list.

3.	 Press the ENTER on the keyboard or click elsewhere in the application. An Undo button appears in the Undo 
column. (If this button does not appear, no programmable change has been made.)

4.	 Repeat Steps 1–3 for each additional parameter to be changed.

NOTE: An individual change can be undone by clicking a button in the Undo column. To undo 
all changes, click the UNDO ALL CHANGES button.
5.	 Click PROGRAM ENGINE and follow the popup messages.





A
S

C
 C

o
m

u
n

ic
a
ç
ã
o

 T
é
c
n

ic
a
 -

 w
w
w
.a
sc
co

m
u
n
ic
a
ca

o
.c
o
m
.b
r

MWM MOTORES DIESEL 
 www.mwm.com.br

"The content of this material was developed to reflect the reality in 
the best way possible at the time of its publication”

"MWM Motores Diesel reserves the right to modify or change its 
contents without notice."

The copy or the total or partial reproduction of this publication is not 
allowed.

For questions or further clarification contact:
Network Development and Service

or
Your Regional Representative

Phone: 0800-110229
asistencia@navistar.com.br
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