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SAFETY INFORMATION

This manual provides general and specific maintenance procedures essential for reliable engine operation
and your safety. Since many variations in procedures, tools, and service parts are involved, advice for all
possible safety conditions and hazards cannot be stated.

Read safety instructions before doing any service and test procedures for the engine or vehicle. See related
application manuals for more information.

Obey Safety Instructions, Warnings, Cautions, and Notes in this manual. Not following Warnings, Cautions,
and Notes can lead to injury, death, or damage to the engine or vehicle.

Safety Terminology

Terms are used to stress your safety and safe operation of the engine: Warning, Caution, and Note

Warning: A warning describes actions necessary to prevent or eliminate conditions, hazards, and unsafe
practices that can cause personal injury.

Caution: A caution describes actions necessary to prevent or eliminate conditions that can cause damage to
the engine or vehicle.

Note: A note describes actions necessary for correct, efficient operation.

Work Area

• Keep work area clean, dry, and organized.

• Keep tools and parts off the floor.

• Make sure that the work area is ventilated and well lit.

• Make sure that a First Aid Kit is available.

Protective Measures

• Wear protective safety glasses and shoes.

• Wear correct hearing protection.

• Wear cotton work clothing.

• Wear sleeved, heat protective gloves.

• Do not wear rings, watches, or other jewelry.

• Restrain long hair.

Vehicle

• Shift transmission to neutral, set parkingI brake, and block wheels before doing
diagnostic or service procedures.

• Clear the area before starting the engine.

Safety Equipment

• Use correct lifting devices.

• Use wheel chocks and stands.



Engine

• The engine should be operated or serviced only by qualified individuals.

• Provide necessary ventilation when operating engine in a closed area.

• Keep combustible material away from engine exhaust system and exhaust manifolds.

• Install all shields, guards, and access covers before operating engine.

• Do not run engine with unprotected air inlets or exhaust openings. If unavoidable for service
reasons, put protective screens over all openings before servicing engine.

• Turn engine OFF and relieve all pressure in the system before removing panels, housing covers, and caps.

• If an engine is not safe to operate, tag the engine and ignition key.

Fire Prevention

• Make sure that charged fire extinguishers are in the work area.

NOTE – Check the classification of each fire extinguisher to make sure that the following fire types can
be extinguished:

1. Type A – Wood, paper, textiles, and rubbish

2. Type B – Flammable liquids

3. Type C – Electrical equipment

Batteries

• Always disconnect the main negative battery cable first.

• Always connect the main negative battery cable last.

• Avoid leaning over batteries.

• Protect your eyes.

• Do not expose batteries to flames or sparks.

• Do not smoke in workplace.



INTRODUCTION

INTRODUCTION

Figure 1 Diamond Logic Builder

In 2001, Navistar, Inc, formerly known as International Truck and Engine Corporation, introduced the industry’s
first high–performance trucks. With this introduction, a very innovative and flexible electrical system employing
multiplexing technology was introduced. The system is standard on all high performance trucks and several
bus models. In addition, there are many options that can be ordered and / or added to the vehicle in the field.

The Diamond Logic® Builder (DLB) software combines the feature creation, programming, and diagnostic
functions for the end user. This Diamond Logic® Builder User’s Manual describes the software in detail and
shows how to use it to maximize the efficiency and effectiveness of the industry’s first high performance truck’s
electrical system integration.
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INTRODUCTION

WHAT IS MULTIPLEXING?

Multiplexing is the technology of transmitting multiple unique electronic signals over one or two wires instead of
over a bundle of many wires. Vehicular applications of multiplexing technology typically use just two wires for
this function. Multiplexing allows these two wires to carry electronic data that can control a variety of electronic
equipment. The number of wires needed to connect components is greatly reduced, which offers better
reliability and improved vehicle uptime. Although limited multiplexing had been used previously by Navistar,
the introduction of the industry’s first high performance trucks has fully implemented this technology.

COMPONENTS OF THE MULTIPLEXING SYSTEM

The multiplexed electrical system consists of the following components:

• Body Control Module (BCM)

• Remote Power Module(s)

• Remote Air Solenoid Module(s)

• Electronic Gauge Cluster

• Switch Packs

• Light Control Module (LCM)

• HVAC Controls

• Engine Controls

• Transmission Controls

• ABS Module

• Door Pods

• Stalk Shifter

• Tire Pressure Monitoring System (TPMS)

• CAN Based Headlight Modules

• Electronic Lift Axle Module (ELAM)

• Other modules, connected to a Data Link, supported by DLB
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INTRODUCTION

Body Control Module (BCM)

The Body Control Module (BCM) is a body systems computer used to control many of the vehicle's electrical
functions. It is the heart of the multiplex system. When installed on trucks, all BCMs are located on driver-side
lower kick panel. On bus applications, they are mounted to the underside and center of the dash.

The BCM receives inputs from driver controls, sensors, and switches providing outputs to vehicle loads,
gauges, relays, and remotely mounted modules. Software to control a vehicle’s specific electrical / electronic
features and components is programmed into the ESC / BC using a computer and the Diamond Logic®

Builder program.

Navistar has released three different generations of the BCM (Figure 2).

1. Electronic System Controller
(ESC)

2. Generation 2 Body Control Module
(BCM)

3. Generation 4 Body Control Module
(BCM)

Figure 2 Three Generations of Body Control Module (BCM)

NOTE – The BCM is commonly referred to as Vehicle Control Module (VCM), Electronic System
Controller, as well as the Body Control Module.
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Remote Power Module (RPM)

Remote Power Modules serve as gateways into Navistar’s electrical system. BCM programming allows
modules to be programmed to control many different types of added body equipment. The base package
for integration includes a module, which contains six 20-amp outputs, for controlling lights or other loads
required for a vehicle’s application (up to 80 amps total). Remote power modules may be controlled using
pre-engineered features from Navistar or special customer developed features created using Advanced Logic
in the Diamond Logic® Builder program. Remote Power Modules also include six inputs that can provide
remote switching and feedback capability.

1. J4 output connector
2. Remote power module
3. Power supply

4. Terminating resistor
5. Body data link controller
6. J3 remote input connector

Figure 3 Remote Power Module
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Remote Air Solenoid Module (RASM or MSVA)

Through the development of a family of Remote Air Solenoid Modules, air accessory devices such as horns,
Power Takeoffs (PTO), sliding fifth wheel locks, suspensions, transfer cases, differential locks, power divider
locks, auxiliary transmissions, and two-speed axles and more can be controlled by electric in-cab switches.
Currently, there are two types of Remote Air Modules, a seven-channel and a four-channel version. Both are
factory installed with in-cab switches. The solenoids can operate as normally open or normally closed.

NOTE – The seven-channel module is not available in post-2007 vehicles.

Figure 4 Seven-Channel Air Module

Figure 5 Four-Channel Air Module
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Electronic Gauge Cluster (EGC)

Located in the instrument panel, the Electronic Gauge Cluster includes the instrument gauges, warning
indicators, and an LCD digital display. The LCD digital display provides odometer, transmission gear indication,
compass heading, and outside temperature displays. The instrument cluster displays the crucial operational
functions of the vehicle. The number of gauges and their placement can vary depending on the options
selected. An audible alarm can be programmed in DLB to sound when certain gauge values read out of range.

The cluster’s gauges are controlled by the BCM via the J1939 Data Link.

Figure 6 Base Instrument Cluster

The Base Instrument Cluster displays numerous functions, alerts, and indicators through analog gauges,
indicators, and an information LED screen. Depending on the cluster configuration that is selected, there can
be six to eight analog gauges in the instrument cluster that provide information to the operator. The Base
Instrument Cluster is available on 2017 and later International® vehicles.

An LED screen is located in the middle of the cluster that displays vital information to the operator. A push
button, located on the right, is used to scroll through the various menus.
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Figure 7 Premium Instrument Cluster

The Premium Instrument Cluster is an upscale version of the EGC. The cluster displays numerous functions,
alerts, and indicators through analog gauges, indicators, and an information LCD screen. Depending on
the cluster configuration that is selected, there can be six to eight analog gauges in the instrument cluster
that provide information to the operator.

The Premium Instrument Cluster uses a 5-in LCD screen, located between the tachometer and speedometer.
There are various menus that can be navigated through using the Cluster Display Control (CDC). The CDC
is located on the instrument panel to the lower right of the Instrument Cluster. A toggle joystick allows
the operator to scroll through various menus, and when pressed, a selection is made. The back button,
represented by an arrow, can be used to return to previous menus and screens.
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Rocker Switch Packs

The Rocker Switch Packs are provided in 6-switch and 12-switch modules. Commonly found in the center
panel, they are used to control loads such as fog lights, heated mirrors, and Power Take Off (PTO) options.
Diamond Logic® Builder software makes it easy to move and relocate switches.

Figure 8 Rocker Switch Pack 2007 – 2016 (Typical)

Figure 9 Rocker Switch Pack 2016 – Present (Typical)

When multiple switch packs are used, they are daisy-chained together to eliminate excess wiring. Switch
actuators control the signals that are sent from the switch pack.
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On vehicles built between 2007 and 2016, the switch pack communicates on the switch data link. Switch
packs on these vehicles have a GREEN Light Emitting Diode (LED) indicator that provides the operator with
information on the load and switch status.

On vehicles built in 2017 or later, the Switch Pack(s) communicate on the Human Machine Interface (HMI)
data link. These switch packs have an LED indicator with 7 different color options. The color of the LED is
dependent on the programmed feature code of the switch or the custom logic that is assigned to the switch.

Light Control Module (LCM)

The Light Control Module (LCM) contains a light multi-switch for the fog lights, headlights, parking lights, and
the option for rear fog lights.

1. Headlight multiswitch
2. Dimmer dial

3. Switch actuator 1
4. Switch actuator 2

Figure 10 Light Control Module (Typical)

The LCM is located in the dash panel on the left side of the steering wheel. The LCM communicates with the
Body Control Module (BCM) over the Low Speed HMI data link. The LCM also contains space for two optional
switch actuators, which can be changed and programmed with DLB.

9



INTRODUCTION

HVAC Controls

An electronic module located in the center of the instrument panel controls the HVAC system. The HVAC
controls eliminate complexity by controlling functions such as the air temperature and air outlet selection
with electronic motors.

Figure 11 Two Examples of HVAC Control Panels

Engine Control System

The engine control module shares engine information such as RPM, vehicle speed, water temperature, and oil
temperature with any component connected to the data link that requires the information. The engine also
receives commands for cruise control, clutch and brake status, and engine fan control from the BC / BCM.

Electronic Transmission Controls

The transmission controller communicates gear position, transmission oil temperature, and warning light status
with the electronic gauge cluster on the drive train J1939 Data Link.

Antilock Brake System (ABS)

The Antilock Brake System prevents wheel lock-up during vehicle braking events. The system communicates
with the BC / BCM and the engine controller to limit engine torque, disable retarders, and control the ABS, ATC
and trailer ABS warning lamps in the electronic gauge cluster.
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THE DIAMOND LOGIC® BUILDER SOFTWARE

Diamond Logic® Builder software provides the ability to program, diagnose, and simulate features in the Body
Control Module (BCM) module. The Diamond Logic® Builder program allows users to configure switches, the
gauge cluster, the parameters that are programmed in the BC / BCM, and programming and diagnosing the
Tire Pressure Monitoring System (TPMS) system.

The Advanced Logic capability in DLB is covered in a separate manual. Advanced Logic provides the ability
to write custom features beyond what is offered by the advertised feature codes. It is not usually offered at
the Dealer level and is primarily intended to be used by Body Builders. Dealers do have the ability to view
and diagnose Advanced Logic when it has been installed on a vehicle.

Figure 12 Diamond Logic® Builder, Main Window
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GETTING STARTED

GETTING STARTED
SYSTEM REQUIREMENTS

Minimum Requirements

• 150 MB of free hard disk space

• Internet connection

Recommended Requirements

• Pentium® IV class processor or greater

• 1 GHz processor or faster

• High-speed Internet connection

• 500 MHz processor or faster

• Windows® 7 or greater

• 512 MB of RAM minimum

• One or more RP1210A compatible communication devices (See Recommended Adapters below)

Improved system performance will occur with the installation of increased RAM

Recommended Adapters

• NEXIQ™ Technologies – USB-Link2

• Dearborn Group Technologies – DPA 5

• Noregon® Systems, Inc. – DLA+, DLA+ Wireless

Other interface cables MAY work with the Diamond Logic® Builder program.

Communication Link Drivers

• DLB uses standard RP1210A drivers for communication. The drivers are specific to the
communications device and are not installed with DLB.
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INSTALLING THE DIAMOND LOGIC® BUILDER SOFTWARE

To install the Diamond Logic® Builder software:

NOTE – If you do not have a User ID, you are a new user. If you have a User ID, you are a current user,
even if you have never used it. If you are part of the OnCommand, you have an User ID.

1. Prior to installation, a DLB product key must be obtained for each computer on which the DLB software is
to be installed. Product keys expire after a year and must be reactivated to allow access to the program.

2. Using the web browser of your choice, navigate to the Diamond Logic® Builder page in Navistar’s site:

https://navistarservice.snapon.com

3. From the home page, search DLB in the upper right-hand corner and select DLB Software.

4. Select Installation Instructions tab to follow the step by step instructions to install the software.

Installation Error Messages

The error code(s) that may appear during the installation process are self-explanatory. Refer to the Documents
tab for the Navistar Software 800 Codes document.
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LAUNCHING THE DIAMOND LOGIC® BUILDER SOFTWARE

NOTE – For installation instructions, refer to Installing the Diamond Logic® Builder Software (page 13).

To launch Diamond Logic® Builder, do one of the following:

• Double-click the Diamond Logic® Builder program icon on the Windows desktop.

• Select Diamond Logic® Builder from the Programs list in the Windows Start menu.

Figure 13 DLB Program Icon

After a few moments, the following Navistar message will appear:

Figure 14 DLB Splash Page
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The User Authentication window appears. Enter your DLB username and password and click OK.

Figure 15 User Authentication Window

NOTE – It is possible the user will also see a brief notice that the software is updating. If software
updates are available, they occur when the user starts the program, while connected to the Internet.
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GETTING STARTED

When the Diamond Logic® Builder software is started, the main window is displayed (Figure 15).

1. Select tab 2. VIN / Name column

Figure 16 DLB Main Window
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The following message (Figure 16) may be displayed as the Diamond Logic® Builder software is started.

Figure 17 Delete Selected Vehicles

NOTE – If this message is displayed (Figure 16), reduce the number of vehicles displayed in the Select
tab (Figure 23 Item 1, Item 2). Doing so can enhance system performance.

To delete a vehicle:

1. Right-click on a vehicle file as shown highlighted in Figure 15.

2. Select delete.
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CONNECTING TO THE VEHICLE

The computer is connected to the vehicle using a RP1210A compliant interface device.

NOTE – Navistar requires a RP1210B compliant interface cable that supports J1939 and J1708 standard.

Figure 18 NEXIQ USB Link 2 Interface Device

There are two cables included with the interface device. One of the cables links the Data Link Connector (DLC)
on the vehicle to the interface device.

18



GETTING STARTED

On most International® trucks, the Data Link Connector is located underneath the instrument panel, to the far
left, on the driver-side.

On most IC Bus® models, the Data Link Connector is located underneath the instrument panel, in the middle of
the panel.

Figure 19 Data Link Connector

The other cable connects to a USB port on your EZ-Tech® / computer to the interface device.

Figure 20 EZ-Tech®
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GETTING STARTED

Preferred interface devices are available from Navistar. However, other interface cables MAY work with the
Diamond Logic® Builder program. The type of cable being used needs to be selected in the Diamond Logic®

Builder program. In addition, the correct cable driver needs to be installed on the computer.

Figure 21 Selecting the Interface Cable Type

Contact the interface cable supplier or visit the supplier’s website for updated software drivers.

NOTE – If communications problems are experienced with one of these cables, disconnect the cable
from the truck, then reconnect and try again. Pressing the F6 key on the computer will toggle between
activating and deactivating the Com Link.
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GETTING STARTED

VERIFYING THE CONNECTION BETWEEN THE COMPUTER AND THE VEHICLE

This section describes how to tell if the vehicle is connected correctly to the computer. Launch the Diamond
Logic® Builder software and then connect the interface cable between the computer and the vehicle.

1. Connect / Disconnect toolbar icon 2. Connect / Disconnect indicator

Figure 22 Main Window, Connected / Not Connected Icons

The Connect / Disconnect indicator (shown above disconnected) is in the lower right corner of the Main
Window. The Connect / Disconnect toolbar icon will also reflect the current connection status.

The icon as shown below indicates that the computer is properly connected and is communicating with the
data link in the vehicle.

Figure 23 Connected Icon
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If the computer is not connected or communicating with the data link in the vehicle, it will appear as shown
below:

Figure 24 Not Connected Icon

NOTE – If the interface cable is connected correctly to the computer and this icon does not appear,
check to ensure the correct cable is assigned to the applicable port under the Tools menu. In addition,
ensure that the correct port has been selected and that the Com link is active.

The indicator lights, on the Interface Cable, should identify when the cable is connected and functioning
properly. If the Diamond Logic® Builder software does not show a Connected icon, tap the F6 key on the
computer. Communication with the truck should resume in a few seconds.

When the computer, running the DLB software, with a properly configured interface cable, is connected to
the module, a status line will scroll across the bottom of the DLB screen. After data has been collected, the
module information should be populated in the Detected column of DLB. If this column is not populated, DLB
is not communicating with the module.

NOTE – You will not be able to Diagnose or Program a module when the module information does not
populate the Detected column.

If the module information does not populate the Detected column, recycle the key, then disconnect and
reconnect the interface cable from the diagnostic connector on the truck.

If you cannot connect to the module, try to connect to another truck to rule out a problem with your computer
or interface cable. Try to connect to the module with a different computer and interface cable to eliminate a
problem with the truck or module.
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MENU AND TOOLBAR OPTIONS
In this section, the menus and toolbar will be briefly outlined. In subsequent sections, the various windows,
buttons, and functions will be described in detail.

MAIN WINDOW

This is the main window of the Diamond Logic® Builder program.

1. Menu bar
2. Toolbar

3. Row of tabs

Figure 25 The Main Window

Each of the three items called out in the figure above provide access to some of DLB’s functions, and each
will be covered in detail in the following sections.
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MENU BAR

The menu bar at the top of the main window contains seven drop-down menus.

Figure 26 Menu Bar

The menus are defined as follows:

Name Description

File Used to manage vehicle data.

Edit Used to manipulate and edit vehicle data.

View Used to view data from different perspectives.

Advanced Logic Used to view any advanced logic programmed on the vehicle.

Tools Used to manipulate data when connected to selected vehicle.

Diagnostics Used to troubleshoot a vehicle.

Help Used to access the software’s help system.

Each menu is described in detail in the following sections.
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File Menu

Figure 27 The File Menu

Name Shortcut Description

New Ctrl+N Opens the New Template window, which is used to define a new template
from scratch (page 98).

Get From
History Ctrl+H Opens a window that allows VIN files to be requested from Navistar over

the Internet (page 93).

Make Template Ctrl+M Allows the operator to make a template by copying a selected VIN or
template (page 99).

Save Ctrl+S Saves changes made to a VIN.

Revert... Ctrl+R Allows the operator to undo changes and revert to a previously saved
version of the VIN.

Delete Deletes the selected vehicles.
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Name Shortcut Description

Set Vehicle
Directory... Sets the default directory in which DLB will save VIN and template files.

Import... Ctrl+I

Imports vehicle file(s) from a folder other than the default directory.

(The import and export functions are typically used to copy files from one
computer to another.)

Export... Ctrl+E Exports vehicle file(s) to a folder other than the default directory.

Print Vehicle... Ctrl+P Prints all vehicle parameters and information.

Print General... Ctrl+Shift+P
Prints screen information of vehicle selection. This function changes when
you change tabs. For instance, if you just want to print the switch positions,
go to the Center Panel tab before you select the File menu.

Close Alt+F4 Closes the DLB program.

NOTE – These menus could contain additional items depending on your DLB access permissions.
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Edit Menu

The Edit Menu allows the user to manipulate and edit data.

Figure 28 The Edit Menu

The items in this menu are defined as follows:

Name Shortcut Description

Apply
Templates Ctrl+T Applies a template to a selected vehicle. (page 101).

Update
Software

Updates Navistar software features without any programmable parameter
changes.

Use Default Allows resetting of pin mapping, gauge location, and switch mapping to default
locations.

Add Modules Adds modules to the selected vehicles and templates.

Remove
Module Removes modules from the selected vehicle.

Apply Selected
Campaign Applies any selected campaign that is shown in the Campaign tab.

Cut Ctrl+X Same as the standard Windows editing function.

Copy Ctrl+C Same as the standard Windows editing function.

Paste Ctrl+V Same as the standard Windows editing function.
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View Menu

The View Menu allows the user to view additional data and / or change the units of the data.

Figure 29 The View Menu

The items in this menu are defined as follows:

Name Description

Unsent History All vehicle programming files that have not been sent to Navistar.

Advanced
Diagnostics All vehicle signals in diagnostics.

Roles Available permissions when the user is logged in correctly.

Units

Allows selection of measurement system.

English: uses English units for measurements.

Metric: uses metric units for measurements.

Refresh Rereads data and refreshes screen display.

28



MENU AND TOOLBAR OPTIONS

Advanced Logic Menu

Advanced Logic allows the user to view logic blocks. Advanced Logic is active only when a logic block
under the Advanced Logic tab is selected.

Figure 30 The Advanced Logic Menu

The Advanced Logic menu includes the following items. There are more options displayed when logged in with
Advanced Logic permissions.

NOTE – Advanced Logic programming is available only to personnel trained and certified at this level.

Name Description

Print Prints ladder logic and selected logic block.

Ladder Details Shows mapped signals on ladder.
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Tools Menu

Figure 31 The Tools Menu

NOTE – Items and functions displayed in the tools menu will be based on user access level.
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NOTE – Items and functions displayed in the tools menu will be based on user access level.

NOTE – Setting the Odometer is restricted to Dealer Level users only.

Name Shortcut Description

Activate Com Link F6 Turns on / off continuous controller hardware scan on communications link.

Electric Lift Axle
Module (ELAM)

Restores the Electric Lift Axle Module programming when the module
programming update fails and the ELAM module is not included in the
detected module list.

Select Com Link Allows for the selection of a communications port to match selected cable.

Set General Alarm
Cluster Volume Adjusts the General Alarm Cluster volume.

Set CMS Alarm
Cluster Volume Adjusts the Collision Mitigation System Alarm Cluster volume.

Recover HVAC
Restores the Front HVAC Module programming when the module
programming update fails and the HVAC module is not included in the
detected module list.

Tire Pressure
Monitoring

System (TPMS)
Programming

Configures Tire Pressure Monitoring System (TPMS) (If Equipped).

Switch Pack
Programming Configures switch packs.

Get Data F7 Reads vehicle data from controller.

Set Odometer Programs the current mileage into the gauge cluster (page 157).

Program F8 Writes selected vehicle configuration into controller.

Reboot Module Allows a reboot of a module without disconnecting the power feed to the
unit.
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Diagnostics Menu

The Diagnostics Menu allows the user to diagnose a vehicle. Most diagnostic items may be used only when
the Diamond Logic® Builder program is placed in Diagnostic Mode.

Figure 32 The Diagnostics Menu

The Diagnostics Menu contains the following items:

Name Shortcut Description

Erase Faults F10 Erases diagnostic faults.

Diagnose F9 Places DLB into Diagnostic Mode while connected to a vehicle.

Simulate F11 Places DLB into Simulate Mode. No vehicle connection required.

Simulate Slowly
When DLB is in Simulate Mode, adjust the speed of the
simulation. This is typically used to slow down simulation speed
when attempting to observe events that occur very quickly.

Cluster Bulb Test Turns On / Off all ESC / BC driven (not CF model) gauge cluster
warning lights.

Indicator Lights Test Turns On / Off all ESC / BC driven (not CF model) indicator lights.

Record / Arm Starts / Stops DLB Data Recorder.
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Name Shortcut Description

Edit Triggers Sets up signal triggers for recording.

New Sessions Opens a new signal recording session.

Open Session Opens an existing signal session.

Save Session Saves a signal session to the computer memory device.

Save Session As Closes any open Session.

Close Session Closes any open Session.

Save Graph Data Saves recorded signal graph data to a specified file.

Open Graph Data Opens a recorded signal graph data from a specified file.
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Help Menu

The Help menu allows the user to seek information about the program’s terms and processes.

Figure 33 The Help Menu

Name Shortcut Description

Help F1

Opens Help function. Help includes: configuring vehicles,
Advanced Logic, programming icon types, ladder logic,
structured logic, units of measure, diagnostics and
acknowledgments

About Diamond Logic® Builder Shows the Diamond Logic® Builder program version information.

Change log Opens web site that identifies the most recent DLB version and
database.

Messages
Displays messages from the system when a user is online.
These messages appear at login if they are not turned off, on
the message window.
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Name Shortcut Description

Send Logs

View Logs
Logging is used only by DLB support and should only be turned
on when directed by engineering.

Registration...

Displays registration information for DLB on this system and
other computers using the same product key.

If you have a multiuser license for the DLB software, the first
user to install the software with your product key becomes the
administrator for the individual user licenses. Some items on this
menu are visible only to the administrator.
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Registration Sub-Menu

Name Description

View Registration
Information...

Provides information about the product key, including parts of the key values,
the system name associated with the key, and information about time left
before the expiration expires.

Extend / Change Edition... Provides the option to enter a new product key to change or extend the
days left until the registration expires.

Request Additional Users... This option requests additional Usernames to be used with DLB.

Unregister this machine...

This option unregisters the current installation of DLB. This will force DLB
to close. Reopening DLB on this computer will automatically reregister the
installation. To use this Product ID on another computer, install it on the other
computer before reopening it on this computer.

Figure 34 Registration Information Window
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TOOLBAR

The toolbar at the top of the main window displays buttons that correspond to many frequently used functions
in the menu bar.

Figure 35 The Toolbar

The icons in the toolbar include the following:

Item Icon Description

1 Create a new template.

2
Save vehicle and template changes on your computer. However,
changes will not be programmed into the vehicle until the program
function is invoked.

3 Apply configuration to selected vehicles.

4 Get vehicle information from Navistar.

5 Update Navistar® software features and kernel on selected vehicles
without any application or programmable parameter changes.

6 Print configuration for selected vehicle.

7 Turn On / Off continuous controller hardware scan on communications
link.

8 Read vehicle data from controller.

9 Write selected vehicle configuration into controller.
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Item Icon Description

10 Edit vehicle mode for the selected vehicle. Turns off Diagnostic Mode
and Simulate Mode.

11 Places DLB in Diagnostic Mode when controller is detected on
communications link.

12 (GREEN) Places DLB in Simulate Mode for the selected vehicle
configuration.

13 (RED) Adjust the speed of the simulation.

14 Clear fault log and previously active faults from cluster.

15 Start signal recorder when controller is detected on communications
link.

16 Go online / offline with the Internet connection.
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TABS AND SUBTABS
USING DATA TABLES IN THE DLB INTERFACE

Most of the tabs in DLB display their information as a table. The tables provide a number of functions for
viewing and sorting the presented data:

• Enable or disable the display of each column

• Sort rows by the contents of a selected column

• Bring rows that contain specified text or values to the top

• Change the width of individual columns

Enabling and Disabling the Display of Individual Columns

Right-clicking any column heading will display the Column Selection menu.

Figure 36 Column Selection Menu

Selecting a column name in this menu adds or removes its check mark.

• Checked columns will be displayed in the table

• Unchecked columns will be hidden in the table

NOTE – Most column selection menus in DLB include two final items that are NOT column names: Sort
matching rows to the top and Clear matches. These functions are part of DLB’s Filter Feature (page 41).
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Sorting Rows by the Contents of a Specific Column

Left click any column header to sort the list by the contents of that column. Clicking the same heading again
reverses the order of the sort (indicated by the up or down arrow on the right end of the clicked heading).

Figure 37 Sorting Downwards by Contents of Parameter Column

Figure 38 Sorting Upwards by Contents of Parameter Column

Note that each column has its own sorting rules:

• A column that contains text entries is typically sorted alphabetically.

• A column that contains numerical entries is typically sorted by value.

• A column whose entries are all checkboxes typically would sort the entries into
checked items vs. unchecked items.
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Bringing Rows That Contain Specified Text to the Top

Refer to the figure below for items in parentheses.

1. Filter button 2. Find window

Figure 39 The Filter Feature

1. Click the Filter button (Item 1) in the upper-left corner of the table. The Find window appears (Item 2).

2. Enter the text that you wish to search for.

3. Click OK.

Any rows that contain a match for the entered text will now appear at the top of the table with a mark on the
left. See highlight on Figure 40.

NOTE – The Find window can also be opened by selecting Sort matching rows to top in the Column
Selection Menu (Figure 36).

To return the rows to their original order, select Clear Matches in the Column Selection Menu (Figure 36).

Changing the Width of Columns

1. Column border (3)

Figure 40 Column Width

The width of columns can be changed by clicking the border between any two column headings (Figure 40,
Item 1) and dragging the border to the left or right.
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SELECT TAB

The Select tab is shown by default when the program is started. This is the main page and is used to select the
vehicle, to display relevant information, and to manage vehicle data. When using any of the other tabs, the
user can return to this main page by using the Select tab.

Figure 41 The Select Tab

Descriptions of Columns on the Upper Half of the Tab

The columns that can be displayed in the top portion of the Select tab include the following:

Column Name Description

VIN Vehicle Identification Number

Template Displays the ESC / BC serial number either from History or from the installed
ESC / BC, depending on the source of the VIN

Configuration Version The number of times this VIN or template has been modified

Status Current status of the file, for example, modified or unsaved
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Column Name Description

Base Revision The revision of the VIN, before the current configuration

Model Sales model of the vehicle

Software Version Software version tied to the file

Last Changed By The ID of the last person to change the file

Last Changed Date When the file was last changed

VIN Right-Click Menu

Right-clicking a VIN will open a drop-down menu. The options in this menu can also be found in various menus
of the menu bar. However, they are collected in this drop-down as a convenience to the user.

Figure 42 VIN Right-Click Menu
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Selecting a VIN

1. Advanced Logic tab
2. Connectors tab

3. Center Panel tab
4. Cluster tab

Figure 43 Additional Tabs Displayed When a VIN Is Selected

Click on a listed VIN to select it. Four additional tabs are displayed when a VIN is selected (Figure 43, Items 1,
2, 3 and 4).

The Module List

When a VIN is selected, a list of the modules programmed on the vehicle will be displayed in the bottom part of
the window. When you are connected to a vehicle, this list will be displayed if the module is communicating
with the ESC / BC.

Figure 44 The Module List
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Right-clicking on any of the modules will open a drop-down menu that may provide additional options for that
module. Options that are grayed out are not available for the selected module.

Figure 45 Module Right-Click Menu

The options in this menu are listed below:

Name Description

Update Module Updates Navistar software on the selected vehicle.

Get Module Data Reads the selected vehicle configuration from all programmable modules.

Remove Module Removes the selected module from this DLB session. This option does not affect
the programming of the module.

Change Module
Password Changes the module password (only if the module has a password feature).

Program Module Writes the current configuration to the selected module only.

Reboot Module Reboots only the selected module operating program.
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The Right Panel

When a VIN is selected, information about the selected vehicle populates the right side of the window. When
you are connected to a vehicle, DLB will also display information about the detected ESC / BC.

Figure 46 Select Tab Right Panel

The items displayed in this area are listed in the table below:

• Selected Vehicle — Information on the vehicle currently selected.

• Detected — Information on the vehicle connected to DLB.

46



TABS AND SUBTABS

Name Description

VIN Vehicle Identification Number.

Description ESC / BC processor information.

Serial ESC / BC serial number.

Hardware Identifies the version of the ESC / BC.

Configuration Number of times this VIN or template has been modified.

Kernel Identifies the release version of the core program in the ESC / BC.

Data Version Release revision of software feature codes.

State Displays the State of the ESC / BC (Ex: blank).
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ADVANCED LOGIC TAB

This section will describe the Advanced Logic tab and the information displays associated with it.

NOTE – Advanced Logic programming is not available to Level II users. This capability is restricted to
Level III users.

NOTE – There is additional information about Advanced Logic under the Help menu, and a separate
manual provides more detail about Advanced Logic Programming.

Figure 47 Advanced Logic Tab

The Advanced Logic tab allows users to view logic blocks. The tab has four main parts:

• The Advanced Logic List (upper-left)

• Display area (lower-left). The figure above shows the most common display mode – Ladder Logic.

• Variable selection tabs (upper-right)

• Variable listings (lower-right)
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Advanced Logic List

This area of the Advanced Logic tab allows the user to select which logic block the user will be programming
or editing and lists all logic blocks of a selected vehicle or template.

Figure 48 Advanced Logic List

Selecting a Logic Block reveals its particular ladder logic in the display area below. Just below the Advanced
Logic List is three sub tabs that allow the user to choose either the Ladder Logic view (as shown) or the
Structured Logic view (for advanced programmers) and a Diagnostics tab.

NOTE – The Diagnostics sub-tab should contain a detailed description, written by the log block creator.
This should describe the operation of the logic and provide contact information. This can be very helpful
if the creator provides the documentation.

Advanced Logic List Columns

The columns in the Advanced Logic List include the following:

Name Description

Logic Block
Logic Block filename. Logic Blocks make up the advanced logic on a vehicle. It is
a way of organizing advanced programming, such as vehicle lighting in one block,
PTO functions in another, emergency lighting in another.

Proprietary Sets up a check box that allows the user to choose proprietary format.

Description Logic Block description.

Date Edited Date created or edited.

User Identifies the user who last edited this Logic Block.

Active When checked, the Logic Block is included in the vehicle configuration.

IMPORTANT – A vehicle with Advanced Logic set to proprietary may not be easily diagnosed or
serviceable by International® dealers. Diagnostic privileges are restricted to the credentials of the
person who sets Logic Block as proprietary. See the Diamond Logic® Builder Software User Manual –
Advanced Logic Programming (Level 3 Permissions) for more information on proprietary logic.
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Display Area

Once an item in the logic block list is selected, the left-side display area will populate with a ladder diagram
of the programmed functions. The ladder diagrams are created and may be edited in this screen, if the
user has Advanced Logic permissions.

Figure 49 Advanced Logic Display Area

The display area itself is resizable. Using the cursor, the width of the display area can be increased or
decreased. Doing so will also change the width of the other displayed areas.
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My Variables

This area of the Advanced Logic tab allows the user to view variables used in the advanced logic programming,
if there are any, on this vehicle.

Logic Blocks are built using the inputs and outputs of the associated modules in the Advanced Logic tab.
Clicking and dragging these inputs and outputs to the left side of the window allows the user to build what is
known as ladder logic.

Figure 50 My Variables List
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My Variables Columns

The headings under the My Variables tab include the following:

Name Description

Icon Displays the variable name icon that appears in the ladder logic.

Custom Variable
Custom name the user has given to the custom variable.

NOTE: No spaces or symbols such as + - & * # may be used.

Used In The logic block in which the custom variable is used.

Written To Whether it is possible to write to the variable or not.

Timer Whether the variable is a timer or not.

Semaphore The variable can be written to; however, other internal variables may take precedence
over your set variable.

Used True when the variable is used in a logic block or the mapped signal is used on the
vehicle.

Description Custom description the user has given to the custom variable.

Signal / Value The system name for the selected signal.

Unit Unit of measure used to display the variable, such as seconds or On / Off.

CFG Unit The system unit of measure for the selected variable.

Signal Description Description for the variable. If no text is in this field, the parameter is an internal value.

Writable Whether the user can write to this value or monitor it or use it to drive other features.

Enabled On Truck Check if the variable is enabled and used on the truck.
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FEATURES TAB

The Features tab displays features and / or parameters for the selected vehicle.

Figure 51 Features Tab with Features Sub-Tab Selected

The Features tab, which is always available, has three sub-tabs:

• ESC: Always available.

• Custom Logic: Appears when parameters have been assigned by advanced logic.

• Cab Display: Appears when the truck has the applicable cab display.
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Features Sub-Tab

The Features sub-tab is divided into two sections:

• Available Feature list (upper section)

• Programmed Parameter list (lower section)

Additionally, a Make Session button appears at the top of the tab.

Available Features List

This list displays the features available for the selected vehicle and indicates whether each feature is currently
installed.

Figure 52 The Available Features List

The columns in this list include the following:

Name Description

Feature Removing the check from this item hides the Features column in the Available Features list.
This column displays the features available for the selected vehicle, in numeric order.

Description Removing the check from this item hides the Description column in the Available Features
list. This column contains a brief description of each listed feature.

Installed Removing the check from this item hides the Installed column in the Available Features list.
This column indicates whether the feature is installed on the selected vehicle.

54



TABS AND SUBTABS

Programmed Parameter List

NOTE – Not all features will have parameters.

This table lists the programmed parameters for the selected vehicle’s features.

Figure 53 List with Numerical Parameter Selected

When a row is selected in the Programmed Parameters list, a value entry field and a description of the
selected parameter appear below the list.

NOTE – The format of the value entry field displayed will vary depending on the type of programmed
parameter selected. The image above shows a parameter that accepts a numerical value within a
specified range. The image below shows a simple On / Off parameter.

Figure 54 List with ON / OFF Parameter Selected
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The Programmed Parameter list includes the following columns:

Name Description

ID Numerical label to identify the programmed parameter. Useful when speaking with
Tech Central.

Parameter Signal name for the programmed parameter.

Unit The unit of measure for the programmed parameter.

Description A brief description of the programmed parameter.

CFG Value Raw data value used by the ESC / BC software. This column is normally turned off
since it is of no value to the typical user.

CFG Unit This is the unit of measure for the raw data value used by the ESC / BC software. This
column is normally turned off since it is of no value to the typical user.

Set With
Template

When the box in this column is checked, the programmed parameter value will be set on
the vehicle when the template is applied.

The Make Session Button

The Make Session button can be used to create a diagnostic session from the selected feature and will
display the signals that are related to the feature. This is very helpful when trying to select signals to watch,
while diagnosing a feature.

Figure 55 Make Session Button

Refer to the Using “Make Session” to select WATCHED Signals section. (page 181)
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ESC Sub-Tab

The ESC sub-tab displays a list of the programmed parameters installed on the selected vehicle.

Figure 56 The ESC Sub-Tab

The columns on the ESC sub-tab include the following:

Name Description

ID Numerical label to identify the programmed parameter. Useful when speaking with
Tech Central.

Parameter Signal name for the programmed parameter.

Unit The unit of measure for the programmed parameter.

Description A brief description of the programmed parameter.
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Name Description

CFG Value Raw data value used by the ESC / BC software. This column is normally turned off
since it is of no value to the typical user.

CFG Unit This is the unit of measure for the raw data value used by the ESC / BC software. This
column is normally turned off since it is of no value to the typical user.

Sort Matching
Rows to Top Used to find matches anywhere on the table and bring them to the top of the list.

Clear Matches Select this item to clear any found matches and return the list to the sort order for the
most recently clicked column heading.
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FAULTS TAB

The Faults tab allows the user to view and clear diagnostic codes that relate to the vehicle’s body electrical
system.

NOTE – The user must be in Diagnostic Mode with Key ON, Engine OFF for diagnostic trouble codes to
be displayed.

Figure 57 Diagnostic Mode Icon

Enter Diagnostic Mode by clicking the Diagnostic Mode icon in the toolbar while you are connected to and
communicating with the vehicle.

Once connected to a vehicle, with the key in ignition or run position, engine not running, the Faults tab will
display any available faults. However, DLB will display some engine-related diagnostic trouble codes.

Figure 58 The Faults Tab

The columns on this tab are described below:

Name Description

SPN Suspect Parameter Number: Number that indicates the Major System that is
experiencing a failure mode.

FMI
FMI is a number for “Fault Mode Indicator.” Currently this value is always 14 for
“Indeterminate” as per the SAE J1939 specification. The FMI for the Diamond Logic®

electrical system is currently displayed under the Byte 8 column listed below.

Byte 7 Number that indicates the sub-system that is experiencing a failure mode.

Byte 8 Number to describe the detailed fault mode such as open circuit or shorted to ground.

Active Indicator to show whether a fault is currently active or inactive.

OC Occurrence Count: Number of times a fault has gone active and then inactive.

Message Text description of the numerical fault code.
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Name Description

Comment Explanation of Message Description.

Probable Cause Probable cause of the fault.

Pins Module pin and connector associated with the fault code, if applicable.

Module Text name of module associated with the fault code, if applicable.

Address

Text name of module associated with the fault code, if applicable. Address of the
module logging the fault. Currently, this number is always 33 for the ESC / BC.
Recommend turning this column off, leaving more space for other columns, until later
enhancements provide more varied data.

NOTE – The SPN, FMI, Byte 7, and Byte 8 columns together make up the diagnostic trouble code. All
four of these columns should remain selected.
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CONNECTORS TAB

The Connectors tab allows the user to view modules programmed for the selected vehicle. The sub-tabs under
the Connectors tab are used select a module to view.

NOTE – A different view for the BCM will be displayed, depending on the model of the vehicle.

Figure 59 Connectors Tab Showing Electronic System Controller
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Figure 60 Connectors Tab Showing Generation 4 Body Controller

62



TABS AND SUBTABS

Connectors Tab Modules

Each sub-tab under the Connectors tab represents a particular module. If the sub-tab’s name is italicized,
the module is inactive / not configured.

Figure 61 Module Sub-Tabs

The sub-tabs are named as follows:

Name Description

ESC Electronic System Controller

MSVA 1 Modular Solenoid Value Assembly 1

MSVA 2 Modular Solenoid Value Assembly 2

RPM X Remote Power Module X

NOTE – Some selected VINs may not display anything other than the ESC, depending on the model of
the vehicle.
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Module Not Configured

In the figure below, the name of the RPM 2 tab is italicized, indicating it that the RPM 2 module is not
configured. When the tab is selected, it displays the RPM 2 module and its connectors. There are no labels
associated with connectors that are not being used.

Figure 62 Module Not Configured
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Configured Module

In the figure below, the name of the RPM 1 tab is STANDARD FONT, indicating that the RPM 1 module is
configured. When the tab is selected, it displays the RPM 1 module and its connectors.

Figure 63 Configured Module

The connector pin-outs that are used are labeled with the signals associated with that pin. The outside signal
names are internal signals used by the system processor. Other signal names are provided for usage by the
Advanced Logic user. General-purpose names are applied to signals that have not been used by Advanced
Logic. Those signals that are in bold have been used in Advanced Logic features.
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Selecting a Connector

When a module connector is selected, the connector in the module view changes to a dark gray color. The
newly selected connector and pin-out information appears in the right-side pane.

Figure 64 Selecting a Connector

If the connector data is wider than the space provided, horizontal scroll bars will be displayed to allow the user
to scroll left and right.

NOTE – The location of the input signal determines whether it is ground or 12V active. For example in
the figure above, pin 20 is a ground active signal. If it was 12V active, the bold print would be on the left
and RPM1_Input3_GND would be listed on the right in lower case.
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Selecting a Connector Pin

Hovering over the pin with the mouse pointer will cause a brief description of the pin’s function to appear.

Figure 65 Selecting a Connector Pin

When connected to a vehicle and DLB is in Diagnostic Mode, the user can lock on an output connector pin
command in the connector view. When a connector pin label is selected, the Module tab, connector pin, pin
label, and pictured module connector are all highlighted in yellow. Selecting the Signals tab will then display
the highlighted signal for additional information. In the sample figure below, PTO_Output has been selected.
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Signals Tab View of Selected Pin

When a pin is selected, selecting the Signals tab will show the selected pin signal description and details,
if the applicable signal is available in the list of signals selected. Select the ESC Signals sub-tab to see all
signals that apply to this vehicle.

Figure 66 Signals Tab View of Selected Pin
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Selecting Multiple Pin Signals

To select more than one pin, hold down the Control key and then click the desired pins.

Figure 67 Multiple Pins Selected

Deselecting a Pin

To deselect a pin, hold down the Control key and then click on pin to deselect.
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Selecting a Pin Used in Advanced Logic

A pin used in Advanced Logic can be selected by clicking on the pin itself, on the pin command text, or on the
pin request text. The text, the pin, and the Module tab will then all be highlighted in yellow.

Figure 68 Selecting a Pin Used in Advanced Logic
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Selecting the Signals tab will then show the selected pin signal description and details.

NOTE – The signal highlighted will depend on where the user clicks. For example, clicking the pin itself
or the pin name text will highlight the output request signal. Clicking the command text will highlight
the output command signal. See figures below.

Figure 69 Signal View When the Output Pin or Pin Name Is Clicked

Figure 70 Signal View When the Output Pin Command Is Clicked
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To unselect an output pin, hold down the Control key and then click on the pin to be deselected. Alternately,
the user can click on another VIN or template.

Figure 71 No Pins Selected

These functions apply to the ESC and Air Solenoid Module views as well.
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SIGNALS TAB

The Signals tab allows the user to view detailed information about each electrical signal that is available for
use by Navistar engineered features and by Advanced Logic, if applicable.

Several sub-tabs are displayed when the Signals tab when it is selected. Among others, these typically
include ESC Signals, Master List, Watched, and Graph.

The upper section each sub-tab (except Graph) displays a list of signals associated with the selected vehicle.
The lower section displays, if applicable, associated ladder logic as it pertains to the selected signal from
the upper section.

Figure 72 The Signals Tab
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Notice that in the figure below, a help message is displayed. Throughout the DLB program, hovering the cursor
over an item can display help popups such as this one.

Figure 73 Mouse Hover Help Message

Signals Tab Columns

With the exception of the Graph sub-tab, all of the sub-tabs on the Signal tab present data in a tabular format.
All of these tables have the same column headings:

Name Description

Custom Signal Displays the custom signal name assigned by the Diamond Logic® Builder software
user.

Signal Displays internal system name for each signal.

Pins Displays internal system name for each signal.

Signal Type Displays, if applicable, generated signal type such as analog, digital, J1939, or 1708.

Physical Signal Name of the signal used by the system controller. This column would normally not
be displayed since it is of no use to the Diamond Logic® Builder software user.

Index Entry in the electrical system data table. This column would normally not be
displayed since it is of no use to the Diamond Logic® Builder software user.

Description Displays the logic description.

Unit Unit in which the variable is displayed, such as seconds or On / Off.

Watch Displays the watched / not watched selection icon.

Cfg. Unit The unit of the raw data value used by the system. This column would normally not
be displayed since it is of no use to the Diamond Logic® Builder software user.

Name Displays the signal name.
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ESC Signals Sub-Tab

All signals programmed into the selected VIN will be displayed on this tab.

Figure 74 ESC Signals Sub-Tab
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Custom Signals Sub-Tab

This tab displays all Advanced Logic signals used.

NOTE – This tab is displayed only when a VIN has Advanced Logic applied to it.

When the Reel_Gate_Input_Switch signal is highlighted, the lower portion of the window populates with the
corresponding Advanced Logic for the selected signal.

Figure 75 Custom Sub-Tab

Master List Sub-Tab

The Master List sub-tab displays all signals that could be programmed to a VIN. This tab will also display the
Advanced Logic corresponding to the selected signal.
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Watched Sub-Tab

The Watched Tab shows signals that have been selected to be monitored as a result of clicking the “Make
Session” button, by selecting a saved session or by selecting signals while viewing other tabs.

Figure 76 Interlocked Switch Signal – Switch On

Signals to be watched can also be selected from the master or customer signal list. This is done by highlighting
the desired signal and clicking the eye icon. In the figure above, the Interlocked Switch signal has been
selected. Here, the signal output indicates 5 amps. The figure below, however, shows the same signal with the
Interlocked Switch in the center panel Off. Notice that the signal output is now zero.

Figure 77 Interlocked Switch Signal – Switch Off
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Graph Sub-Tab

While in Diagnostic Mode, the Graph sub-tab allows you to view signals that are being “watched” in a
graphical format.

These graphs can be saved for future review.

NOTE – The graphing feature is seldom used as there are other places, connector views, and signal
views where you can watch signal interaction. Setting, arming and using triggers to start and stop
graphs requires some practice.

To select the signals to be graphed, open the ESC Signals tab and click the eyelid icon for each desired signal.
The icon will change to an open eye for signals that have been selected.

Select only the required signals. Viewing too many signals on a graph will make it difficult to distinguish
between them. If it is necessary to deselect a signal, simply click the open eye icon.

Figure 78 Record Icon (Select Trigger)

When selecting the Graph sub-tab, the graph will not be displayed until a trigger is selected and activated or
the Record Button in the toolbar is clicked to arm / disarm the trigger.
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Setting a Trigger

To configure a trigger:

1. In the menu bar, select Diagnostics > Edit Triggers. The Edit Triggers window appears. This is where
the user can select which signal will start the graph in the session.

Figure 79 Edit Triggers: Signal Source Drop-Down

2. In the Signal Source drop-down (upper left corner of the Edit Triggers window), select the source of
the desired signal. For example, if you want to use a signal that is listed on the Watched sub-tab,
select Watched.

Figure 80 Edit Triggers: List of Signals
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3. In the drop-down immediately to the right of the one modified in the previous step, select the specific
signal to use as a trigger.

NOTE – This drop-down lists all the signals from the specified source. So, if Watched had been
selected in the previous step, it would list all of the signals that appear on the Watched sub-tab (in
other words, all signals that the user has chosen to watch).

Figure 81 Set Trigger Conditions – AC_Request ON

4. Specify when the selected signal will trigger recording of the signals to be graphed.

• Rising Edge: Select this option if graphing should begin when the specified signal goes ON / TRUE.

• Falling Edge: Select this option if graphing should begin when the trigger signal goes OFF / FALSE.

• Value: If graphing should begin when the trigger signal reaches a specific value, enter
the desired value. Note that this field may be a checkbox, a text entry field or a
drop-down menu, depending on the type of signal selected.

• Faults: If graphing should begin when a certain number of faults have occurred,
enter the desired number of faults.

5. Specify the number of second that should be recorded after the trigger conditions indicated above are met.

6. Click OK to close the Edit Triggers window.

Figure 82 Record Icon (Signal Trigger)

7. Click the Record icon to start the recording session.
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Figure 83 Graph Sub-Tab, After Record is Clicked

Once the session is running, your graph will start to move.
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Figure 84 Graph Sub-Tab, Recording Changes

8. To see the graph change and the trigger set, force the trigger signal to the condition specified in Step 4.
For example, if the trigger had been configured as shown in Set Trigger Conditions (Figure 81), you
would set the AC_Request signal to ON.

Once the trigger is set, the recording will automatically stop after the post-trigger time has expired.
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Saving Recorded Data

Although it is not recommended, custom sessions can be created and saved for later reference.

Figure 85 Saving a Session

1. In the menu bar, select Diagnostics > Save Session As. The Save Session window appears.

2. Enter an appropriate filename for the saved session. (Session files will be saved with the .dls
filename extension.)

3. Click Save.

NOTE – Be sure to note where your session is being saved to make it easy to find later.

It is also possible to save the graphical data to a .csv file (a file of raw data values, separated by commas).
Such files can be easily imported into spreadsheets and other programs that are used to manipulate and /
or present data.

To save data to a .csv file, select Diagnostics > Save Graph Data in the menu bar.
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CENTER PANEL TAB

The Center Panel tab allows the user to view the vehicle Switch Panel arrangement. Horizontal and vertical
scroll bars appear when needed for full view.

Figure 86 Center Panel Tab, Example 1

Center panel views will vary depending on the vehicle selected. In the figure above:

• The four rows of switches on the left each represent a slot in which a switch pack may be installed. The wire
connection shown between the first two rows indicates that the second switch pack is present and populated.

• The Light Control Module (LCM) appears in the upper right. When the LCM appears
on this tab (rather than the Cluster tab), the two rectangular switches may be dragged
and dropped like any of the switches on the left.

• Up to six auxiliary gauges may appear in the lower right. In this case, there are no auxiliary gauges installed.
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The figure below shows a different vehicle that has four rows in which switch packs may be installed (two of
which are used), but nothing else on this tab.

Figure 87 Center Panel Tab, Example 2

Viewing Switch Feature Codes

Hovering the mouse over a switch will display the feature code associated with that feature.
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CAMPAIGN TAB

The Campaign tab is used to push programming changes that are set up as Campaigns. A Campaign ID will
only be shown if there is a campaign that applies to this vehicle.

Figure 88 The Campaign Tab

A message will display when one or more campaigns are available. To apply the campaign(s), you have to
check the box under Apply column. If the check box is marked in the H/W column, make sure to have the
hardware installed prior to selecting the APPLY SELECTED CAMPAIGN button. The changes will program
when the programming process has completed.
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MESSAGES TAB

The Messages tab allows the user to view configuration errors, warnings and the programming history for
the last programming change.

Figure 89 The Messages Tab
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Upper Panel

The upper panel displays a list of configuration errors (if any).

Figure 90 Messages Tab, Upper Panel

Double-clicking on one of these messages will cause the message to be displayed in a popup window. The
window contains the same text that appears in the Long Message column. However, it may be useful when
that column is turned off or when the message is too long to be fully displayed in the Long Message column.
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Figure 91 Configuration Error Detail
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Types of Errors (What Do They Mean?)

Listed below are some examples of error messages and what causes them:

• Feature xxxxxx and Feature xxxxxx conflict – This error is generated when attempting to add two
features that conflict with one another. For example, if the user tries to add 595259 (a feature for normally
closed solenoids) and feature 595297 (a feature for normally open solenoids), this will generate the error
shown below because the two different types of air solenoids cannot be used at the same time.

Figure 92 Feature xxxxxx and Feature xxxxxx Conflict Message

• XXXX value required by feature XXXXXX is not provided – This error is generated
when parameters that are required by a feature are missing. For example, this error will be
generated if the user tries to add 595179 (BC / BCM Programming for PTO) without adding
a feature that would indicate what type of PTO will be used.

When you add a feature (for example, 595252 – Electric over Air, Non Clutched) that contains
the parameters required by 595179, the error message will clear.

Figure 93 Value Required by Feature XXXXXX Isn’t Provided Message
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• Simulation Error – This error will be generated if the user attempts to simulate a program
within DLB that exceeds the ESC / BC processing time limit.

This error is displayed as a pop-up on the screen that the user is currently viewing.

In order to eliminate this error, have the dealer or Body Builder reduce the number of rungs used
within Advanced Logic or reduce the number of features applied to the truck.

Figure 94 Simulation Error Message
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Columns in the Upper Half of the Messages Tab

The columns in the upper half of the Messages tab include the following:

Name Description

Message Displays a particular error. Double-clicking will produce a pop-up window that displays
the long description.

Type Describes the conflict.

Long Message Describes the conflict in detail.

Trace Trace is meant for debugging software errors and is of no use to most Diamond Logic®

Builder users. This column should be left off.

Columns in the Lower Half of the Messages Tab

The lower half of the Messages tab lists changes that have been made to a vehicle configuration since the
last time it was programmed into a vehicle. This list will be cleared once the new configuration has been
programmed into the vehicle and a new “READ” operation has been performed on the vehicle electrical
system controller.
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DETERMINING THE VEHICLE’S CURRENT CONFIGURATION
GETTING VEHICLE CONFIGURATION HISTORY

The computer must be online connected to the Internet to get vehicle information from history.

Figure 95 Get Vehicle Configuration Icon

1. Open the Vehicle Configuration History Requests window by doing one of the following:

• In the toolbar, click the Get Vehicle Configuration Icon.

• In the menu bar, select File > Get From History

Figure 96 Vehicle Configuration History Requests

2. In the VINs box, type the vehicle’s VIN or the 8-digit chassis number.

3. Click the Request VINs button. The VIN requested appears in the list. Depending upon the usage of the
Vehicle History Service by other users, the system will load your requested vehicle configuration file onto
the computer. This will take from a few seconds to a few minutes.

Figure 97 Confirm Overwrite Window
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4. If the user already has previous copy of the VIN file on the computer, a Confirm Overwrite window
appears. Select YES to override the current vehicle configuration version on the computer and highlight
the vehicle in the listing.

Figure 98 Vehicle Highlighted in List
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ADDITIONAL BUTTONS IN VEHICLE CONFIGURATION HISTORY REQUESTS

The Vehicle Configuration History Requests window has two additional buttons: Remove Selected Requests
and Work Online.

Figure 99 Vehicle Configuration History Requests Window

Remove Selected Requests

Clicking the Remove Selected Requests button will remove the selected VIN request from the list.

Work Online

Selecting the Work Online button, will allow the user to work online or offline. Working “online” means that the
user is connected to the Diamond Logic® Builder program resources at Navistar through the Internet.

Figure 100 Offline Icon (No Signal)

When DLB is being used offline, the icons in the following locations will indicate that there is no signal:

• Work Online / Work Offline button in Vehicle Configuration History Requests window

• Toolbar Go Online / Go Offline button

• File Menu Work Online / Work Offline option.
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OTHER WAYS TO OBTAIN VEHICLE INFORMATION

Connecting to the Vehicle

The user can also get the vehicle information by simply connecting up to the vehicle. This is the most
accurate way.

• If the user does not have a version of the vehicle’s information already, connecting to the vehicle
will automatically read the information contained in the ESC / BC.

• If the user has a version but the vehicle is at a later revision, click the Get Data icon in
the toolbar to read the latest configuration from the vehicle.

Figure 101 Get Data Icon
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CREATING AND APPLYING A TEMPLATE
A template is a separate file that captures and stores vehicle configuration changes that have been performed
using the Diamond Logic ® Builder software. These changes can be any of the following:

• Adding / Deleting 595XXX or 597XXX Features

• Changing Programmable Parameters

• Moving Pin, Switch or Gauge Locations

• Adding or Modifying Advanced Logic Blocks

A template is a programming guide that summarizes the features and parameter settings that are to be
applied to a vehicle configuration. The template can be loaded to a vehicle and can be saved for future use
on additional vehicles. Once a template is saved it can be exported or emailed just like any other data file.
Multiple templates can be applied to a vehicle or a series of vehicles.

IMPORTANT – When multiple templates are required. Create one master template with all required
templates to help minimize programming errors.

There are two options available for creating a template:

• Creating a New Template from Scratch

• Modifying a Copy of an Existing Template
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CREATING A NEW TEMPLATE FROM SCRATCH

1. In the Menu Bar, select File > New. The New Template window appears.

Figure 102 New Template Window

2. In the VIN box, enter a name for this template.

3. For each module to be added to the template:

a. In the drop-down to the left of the Add button, select the module to be added. The options for the
selected module will now be listed in the table below the drop-down.

b. Select the desired value for each listed option.

c. Click Add to add the selected module to the list in the upper portion of the window.

4. Once all desired modules have been added to the list, click OK to create the template.

NOTE – There is currently no GEN 4 BCM.

The new template should now be listed on the Select tab.
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CREATING A NEW TEMPLATE FROM AN EXISTING TEMPLATE OR VIN

It is possible to create a template based on an existing template or VIN. This simplifies the creation of a
template if the new template will differ in only a few options or attributes from the already existing template.

Figure 103 Select Tab

1. On the Select tab, click the existing template to copy.

2. In the menu bar, select File > Make Template. The Make Template window appears.

Figure 104 Make Template Window

3. Enter a template name between 1 – 16 characters in length.

4. Click OK.

The new template will now be listed on the Select tab.
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Figure 105 New Template Listed on Select Tab

On the Select tab, templates will have a GREEN check in the Template column.

TEMPLATE MAINTENANCE

IMPORTANT – It is extremely important to save and back up copies of all templates created or
changed. Navistar does not store or retrieve templates. Until the templates are applied to a vehicle and
the vehicle is programmed, they are just templates on your computer. Navistar only tracks vehicle
information that has been programmed into a vehicle.

IMPORTANT – It is highly recommended that the vehicle configuration be printed whenever
modifications are made to a VIN. These modifications include (but are not limited to): adding, deleting,
moving, or modifying switches, features, advanced logic, or outputs / inputs on the connectors.

The printed vehicle configuration should be stored with the vehicle for future reference in diagnostics, repair,
and modification or reprogramming.
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APPLYING A TEMPLATE

Follow these steps to apply a template and program a vehicle:

1. On the Select tab, select the vehicle to be programmed.

Figure 106 Selecting the Vehicle

2. In the toolbar, click the Apply Configuration icon.

Figure 107 Apply Configuration Icon

The Apply Templates window appears.

Figure 108 Apply Templates Window

3. Select the template to be applied.

4. Check the boxes of your choice in the Apply section.
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5. Click the Apply Selected Templates button. It is possible to select and apply several templates to a vehicle.

Figure 109 Apply Templates Window, with Template Selected

After applying the template, the selected vehicle displays Unsaved Changes in the Status column.

NOTE – It is highly recommended to use the Connectors, Signals, and Features tabs to verify the
accuracy of the pins, switches, and programmable parameter changes the user has made.

6. Save changes to the selected vehicle by doing one of the following:

• In the Menu Bar, select File > Save.

• Click the Save icon in the toolbar.

Figure 110 Save Icon

7. Program the changes into the vehicle (page 119).
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ADDING A FEATURE
1. On the Select tab, select the template or VIN or template to which this feature is to be added.

Figure 111 Selecting a Template

2. Click the Features tab. The upper portion of the tab lists all features that have been developed for the
ESC / BC.

With a VIN selected, the listing is organized in three different columns:

• The Feature column identifies the software identification number for each packet of software
code. These packets are referred to as 595 or 597 codes because the identification number
always starts with either 595 (595XXX) or 597 (597XXX).

• The Description column provides a short text description of the feature.

• The Installed column indicates the installed status of a feature for the vehicle configuration. A
checked box indicates the feature IS installed in the vehicle’s configuration. An unchecked box
indicates that the feature IS NOT installed in the vehicle’s configuration.

NOTE – A grayed out box, with a check mark, means that the feature is active but cannot be changed
with the current user’s permissions.
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Figure 112 Feature List

When a template is selected, you must enable the Added With Template and Removed with Template
columns. To do this, right-click on any of the column headings, and then check the names of these
additional columns in the right-click menu.

With these two active, the listing should have five different columns:

• The Feature column identifies the software identification number for each packet of software code.

• The Description column provides a short text description of the feature.

• The Installed column indicates the installed status of a feature for the vehicle’s configuration. A
checked box indicates the feature IS installed in the vehicle’s configuration. An Unchecked box
indicates that the feature IS NOT installed in the vehicle’s configuration.

• The Added with Template column provides the option to include features in VIN
configurations when this template is applied. A checked box means the associated feature
will automatically be included in all VIN configurations that have this template applied
to them. An unchecked box has no effect on the template.

• The Removed with Template column provides the option to remove features from VIN configurations
when this template is applied. A checked box means the associated feature will automatically
be removed from a VIN configuration when this template is applied to them.
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The listing of features may be sorted in multiple ways. Clicking on any of the column headings will cause
the entire table to be sorted in an ascending or descending order as defined by the column data.

3. Scroll through the available features until the one to be added is found. Check the Installed box to add
the feature.

Figure 113 Feature List, with Feature Selected

The lower half of the tab now displays a list of programmable parameters that are associated with this
feature. Not all features will have programmable parameters.
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Figure 114 Editing Parameter Values

4. Edit the parameter values in the lower half of the window as needed / desired. To edit an individual value:

a. Select the parameter to edit. An editable field for the selected parameter will now appear in the
lower-left corner of the window. A description of the parameter will be displayed in the lower-right
corner.

b. Edit the Value displayed in the lower-left corner. There are three types of values:

• If the parameter permits an ON or OFF value only, there will be a check box. A
checked box indicates the programmable parameter is on. An unchecked box
indicates the programmable parameter is off.

• For parameters that require numerical values, a box is provided to type in the new data value.
An allowable range of values will typically be displayed to the right of the box.

• Other parameters provide the ability to make a choice from a list. Only one choice
from the list may be selected for the feature file.

NOTE – A value can also be edited by clicking in the Value column of the programmable
parameters listing itself.
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Figure 115 Set With Template Checkbox

5. When editing the programmable parameters in a template, ensure that the associated box in the Set With
Template column is checked for each value that has been modified. If this box is NOT checked, the
updated value will not be applied when the template is applied to a VIN.

NOTE – As long as changes are not saved, it is possible to change back to original feature and
programmable parameter choices by selecting File > Revert in the menu bar. Once the file has been
saved, removing feature or programmable parameter selections must be done manually.

Figure 116 Select Tab Status Column – Unsaved Changes

6. Prior to saving, the Status column on the Select tab will indicate that there are Unsaved Changes to the
modified VIN or template (Figure 116). These changes must be saved before they can be programmed
into a vehicle. There are two ways to save changes:

• In the menu bar, select File > Save.

• In the toolbar, click the Save icon.

Figure 117 Save Icon

On the Select tab, the Status column for the modified VIN or template should now be clear for the modified
VIN or template. (It will no longer indicate that there are Unsaved Changes.)
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Figure 118 Status Column on Select Tab Clear

7. Program the changes into the vehicle (page 119).

NOTE – Always refer to the documentation on the Navistar Body Builder website when adding or
removing features or to diagnose and fix any conflicts that may occur.

NOTE – It is highly recommended that the vehicle configuration be printed whenever modifications
are made to a VIN. These modifications include (but are not limited to): adding, deleting, moving, or
modifying switches, features, advanced logic, or outputs / inputs on the connectors.

The printed vehicle configuration should be stored with the vehicle for future reference in diagnostics, repair,
and modification or reprogramming.
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CHANGING PROGRAMMABLE PARAMETERS
It is possible to edit programmable parameters in either a VIN or a template. Be aware, however, that editing
programmable parameters in a VIN will cause the changed values that have been saved to automatically be
programmed the next time the vehicle is programmed.

It is better to create a template from the original VIN and make the parameter modifications to the template.
The template can be applied to the VIN and then programmed in the vehicle.

1. On the Select tab, select the template or VIN whose parameters you wish to modify.

2. Select the Features tab. The upper portion of this tab lists all available features. The lower half of the tab
lists all the parameters available to change on the selected vehicle or template, including their current
value, units, and the ID.

Figure 119 The Features Tab

3. Scroll through the available features and find the feature whose programmable parameters need to be
changed. Select the feature by clicking on its feature number or its description. The lower half of the tab
now displays a list of programmable parameters that are associated with this feature. Not all features
will have programmable parameters.
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Figure 120 Features Tab, with Feature Selected

4. Edit the parameter values in the lower half of the window as needed / desired. To edit an individual value:

a. Select the parameter to edit. An editable field for the selected parameter will now appear in the
lower-left corner of the window. A description of the parameter will be displayed in the lower-right
corner.

b. Edit the Value displayed in the lower-left corner. There are three types of values:

• If the parameter permits an ON or OFF value only, there will be a check box. A
checked box indicates the programmable parameter is on. An unchecked box
indicates the programmable parameter is off.

• For parameters that require numerical values, a box is provided to type in the new data value.
An allowable range of values will typically be displayed to the right of the box.

• Other parameters provide the ability to make a choice from a list. Only one choice
from the list may be selected for the feature file.
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A value can also be edited by clicking in the Value Column of the programmable parameters listing
itself.

Figure 121 Editing the Value Column

5. When editing the programmable parameters in a template, ensure that the associated box in the Set With
Template column is checked for each value that has been modified. If this box is NOT checked, the
updated value will not be applied when the template is applied to a VIN.

NOTE – As long as changes are not saved, it is possible to change back to original feature and
programmable parameter choices by selecting File > Revert in the menu bar. Once the file has been
saved, removing feature or programmable parameter selections must be done manually.

6. Prior to saving, the Status column on the Select tab will indicate that there are Unsaved Changes to the
modified VIN or template. These changes must be saved before they can be programmed into a vehicle.
There are two ways to save changes:

• In the menu bar, select File > Save.

• In the toolbar, click the Save icon.

Figure 122 Save Icon

7. Program the changes into the vehicle (page 119).

NOTE – It is highly recommended that the vehicle configuration be printed whenever modifications
are made to a VIN. These modifications include (but are not limited to): adding, deleting, moving, or
modifying switches, features, advanced logic, or outputs / inputs on the connectors.

The printed vehicle configuration should be stored with the vehicle for future reference in diagnostics, repair,
and modification or reprogramming.
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CHANGING SWITCH, GAUGE AND PIN-OUT CONFIGURATIONS
MOVING CENTER PANEL SWITCHES

Switches on the center panel are generated when programmable features are added to the vehicle on the
Features tab or an advanced logic template when switch features or custom switches are applied.

A switch can be moved by clicking and dragging it to the desired location.

NOTE – Changing the switch location is a function in DLB. DLB changes the switch configuration in the
BCM, and the BCM alone controls this functionality. You are not programming any part of the actual
switch pack when this action is performed. The base programming software level within the switch
pack(s) is known as a kernel, is covered later in this manual.

Figure 123 Center Panel Tab
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In the image below, the MASTER SW was moved to the lower bank by clicking and dragging.

Figure 124 Master Switch Moved to Lower Bank

Hovering over a switch invokes a pop-up that describes the switch. When hovering over a blank, this pop-up
reads Plug (No Switch).
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MOVING SWITCHES ON THE CLUSTER (ON APPLICABLE VEHICLES)

If there are vacant switch locations on the cluster, a switch from the center panel view can be relocated to one
of these locations. To accomplish this:

1. Click on the switch in the Center Panel view.

2. Drag the switch onto the Cluster tab and wait for the Cluster tab to open. (Do not drop the switch yet.)

3. Drag the switch onto the Cluster view and drop it onto the desired vacant location.

Switches can also be moved from the cluster to vacant locations in the center panel.

NOTE – DLB will only let you move a switch to a configurable location.

NOTE –Any switch located on the cluster will be activatedwith the key in theOFF position. This provides
a risk of running down the battery if the switch is left ON.

Figure 125 Cluster Tab with Two Vacant Switch Locations (Lower-Left)
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MOVING GAUGES

The Cluster tab and, on some vehicles, the Center Panel tab allow the user to view the vehicle cluster gauge
and warning light arrangement, as populated by the features enabled in the vehicle configuration. The gauge
positions identified with a BLUE circle are for optional gauges (which may be moved). All other gauges
and warning lights have a fixed position. Full view of the gauge cluster is accomplished via movement of
the horizontal and vertical scroll bars.

Figure 126 Cluster Tab with Two Vacant Gauge Locations (Left)

NOTE – On some models manufactured in 2017 and later, none of the gauges are moveable.
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To move an optional gauge:

1. Drag and drop the gauge to an empty gauge location (BLUE circle).

2. Save changes by doing one of the following:

• In the menu bar, select File > Save.

• In the toolbar, click the Save icon.

Figure 127 Save Icon

3. Program the changes into the vehicle (page 119).
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MOVING SIGNALS TO DIFFERENT CONNECTOR PIN LOCATIONS

There is some latitude to relocate signals to different connector locations on the BC / ESC and the Remote
Power Modules. This capability is limited to relocations that are configurable and are permitted by your
DLB programming level.

DLB will generate an error message if you try to move something where is not permitted.

To move a signal:

1. Drag and drop the desired signal from its current location to a vacant location.

2. Save changes by doing one of the following:

• In the menu bar, select File > Save.

• In the toolbar, click the Save icon.

Figure 128 Save Icon

3. Program the changes into the vehicle (page 119).

Errors

If you do not have sufficient permissions to make the change, the following error will be displayed.

Figure 129 Pin Mapping Error
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If you try to change pin assignments on a template, the following message appears.

Figure 130 Template Pin Assignment Warning

Additionally, new messages that advise why the move is generating an error may appear on the Messages tab.

Figure 131 Error-related Messages on Messages Tab

Use Default

The Use Default option in the Edit menu will return connector pin mapping, parameter values or switch and
gauge locations to the default settings. This can be helpful when configuration conflicts occur. Use this carefully
and be sure to compare anything that might have changed in the DLB interface to your desired configuration.

NOTE – Using the Default Pin Mapping function may undo any custom pin locations.

NOTE – Using the Default All option may help to clear an error message that shows up in the Messages
tab. Use caution to ensure that any undesired changes were not made.
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PROGRAMMING A VEHICLE
MODULE PROGRAMMING

DLB can be used to do the following:

• Program changes that add or remove BC / BCM features and parameters

• Change switch and gauge locations

• Update module kernel versions

• Update switch pack kernel version and assign pack addresses

• Configure the Tire Pressure Monitoring System (TPMS)

The BCM programming is made up of the following discrete software components:

• Base Kernel Program

• Configuration Program, consisting of Features and Logic Blocks

• Programmable Parameter file

If the kernel program on the BC / BCM already contains the latest version available from Navistar, only the
configuration file and programmable parameters would be loaded into the vehicle.

Only VIN files may be programmed into a vehicle. Templates must be applied to a VIN file, saved, and then the
updated VIN file may be programmed into the vehicle.

NOTE – Prior to attempting to program the BC / BCM, ensure that the battery is charged to a least 13
volts and the dome light or park lights are on.

NOTE – Key must be ON when the programming includes updating the Light Control Module or Switch
Pack modules.

NOTE – Prior to programming, vehicle modules should be updated to the latest kernel.

1. Connect the vehicle to the computer using an interface cable. Refer to the CONNECTING TO THE
VEHICLE section for detailed instructions.

Figure 132 Computer Link Icon

2. Click the Computer Link icon in the toolbar.

3. Verify that the connection is established by checking the icon in the lower-right corner of the window. This
icon should show that the vehicle is connected.

Figure 133 Computer Link Connected
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NOTE – If you are programming a replacement BC / BCM, a message will appear warning that the
BC / BCM serial number of the Selected BC / BCM and the Detected BC / BCM do not match.

4. Click OK to allow DLB to change the serial number on the selected VIN. This will marry the new BC / BCM
serial number to the BC / BCM and update the VIN database in the Navistar system.

Figure 134 Program Icon

5. Click the Program icon in the toolbar.

Figure 135 Warning Message

NOTE – Items and functions displayed in the DLB software will be based on user access level.

The message above will be displayed if programming is attempted with the key OFF. Programming is not
recommended to program with KEY OFF. Programming with KEY ON will update all modules as required.
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Figure 136 Programming Status

The system will load the VIN configuration file into the vehicle. The status bar will display the slider bar
showing programming status.

NOTE – Do not interrupt while the program is loading.

6. Once all required sections of the VIN configuration files are loaded, the status bar will indicate that the
system is resetting. The vehicle is now programmed.

Figure 137 Status Column Empty

Notice that the Status column is now empty for the programmed vehicle.

After a vehicle has been programmed, while not connected to the internet, the user must connect to the
Internet and launch the Diamond Logic® Builder software. Connecting to the Internet will allow the Diamond
Logic Builder program to save the revised.

VIN configuration file in the archive at Navistar. For this reason, Navistar suggests making a connection to the
Internet at least once a day, if the user has programmed any vehicles.

NOTE – It is highly recommended that you print the vehicle configuration whenever modifications are
made. These modifications include (but are not limited to): adding, deleting, moving, or modifying
switches, features, advanced logic, or outputs / inputs on the connectors.

The printed vehicle configuration should be stored with the vehicle for future reference in diagnostics, repair,
and modification or reprogramming.
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MODULE UPDATING

The Diamond Logic® Builder software can be used to update the Kernel on modules that are detected on the
truck data links.

NOTE – Switch Pack Module updating is accomplished by using the switch pack Programming option
under the Tools menu.

There are two options that allow users to manually update module software that is capable of being updated:

• Update All Icon

• Update All Software option in the Edit menu

Figure 138 Update All Icon

If the BCM is already at the latest kernel, a message will be displayed, asking if you want to update the
BCM anyway.
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Figure 139 Edit Menu

NOTE – Items displayed in the edit menu will be different based on user access level.

There is also one option in the menu bar that allow users to update module software:

• Select EDIT, then Update Software, then Update All Software to update all modules
that are capable of being updated.

Modules that are not intended to be updated or programmed can be removed.

1. In the lower section of the Select tab, select the Detected Modules sub-tab.

2. Right-click on one of the Detected Modules to see the drop down menu shown below.
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Figure 140 Detected Modules Right-Click Menu

3. Select the desired option. Any module that is not grayed out can be selected.

• The Remove Module option will remove the module form the Detected Module list and
prevent that module from being updated or programmed.

• The Reboot Module option will reboot a module that can be rebooted.
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SWITCH PACK PROGRAMMING

NOTE – The Body Control Module (BCM) software must be at Data Version 324 or higher to support
programming the switch pack software.

If the functionality of one switch pack has relocated to another switch pack, please follow programming
procedures to correct the issue. The modules will no longer be plug and play. Programming is required if
you add or replace a switch pack, or if you want to update the old switch pack programming to the new
programming. Programming the switch pack software is a stand-alone programming function in DLB.

You will need to program and assign the source address to the switch pack modules for them to function
properly. All switch packs must have the same kernel.

1. Switch pack 1 with source address
151

2. Switch pack 2 with source address
152

3. Switch pack 3 with source address
153

Figure 141 Switch Pack Locations

When the switch packs reverse or flip, the switch pack’s original source address (Figure 141) will be reassigned
to one of the other addresses.

125



PROGRAMMING A VEHICLE

Symptoms

DTC / Light Description
33 – SPN 516527 FMI 13 Switch Configuration Mismatch

33 – SPN 516528 FMI 13 Switch Configuration Mismatch

33 – SPN 687 FMI 2 Forward Rear Diff Lock Switch Error

33 – SPN 691 FMI 2 Power Divider Lock Switch Error

33 – SPN 986 FMI 2 Engine Fan Switch Error

Faults will vary based on switch content and configuration. Some possible faults are listed in the chart.

NOTE – If switch packs are flipped and programming is not available, unplug the switch pack 1 for 30
seconds, then plug it back in. This will force all switch packsmodules to perform a source address claim
at their current software level and will restore functionality. Disconnecting the batteries will also work
to force the switch pack modules to perform a new source address claim. There may be truck power
conditions that cause the switch pack operations to be flipped from one switch pack to the other. This
can create extremely undesirable conditions.

Customer observations or concerns are as follows:

• Switch pack switches are flashing RED

• Switches may operate a function of a different switch pack

Example: A switch in switch pack 1 may operate as the switch directly below it in switch pack 2.
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Figure 142 Tools Menu

Programming is required to do one of the following:

• Add or replace switch pack

• Update old switch pack base software kernel to latest kernel

• Adjust source addresses on installed switch packs

You will need to program and assign the source address to the switch pack modules for them to function
properly. All switch packs must have the same kernel.
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1. Switch pack number one with
source address 151

2. Switch pack number two with
source address 152

3. Switch pack number three with
source address 153

Figure 143 Moving Switch Pack Locations

Updating Switch Pack Software (Kernel) Using DLB

Updating the software in the switch pack base, which controls how the switch pack module operates, including
fixed module source address.

NOTE – Moving switch locations and updating the switch pack software are not the same thing.

• Programming software (kernel) within the switch pack base is a function in DLB

• This is not related to moving switch locations

• The procedure to update the switch pack base software (kernel) is being covered in this section
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Diagnostic Steps

Part One – Check existing switch pack software in vehicle

1. If you are replacing a switch pack, check the kernel version of the parts that are currently installed in
the vehicle, as well as the kernel of the new part.

Figure 144 VIN Delete

NOTE – Items and functions displayed in the DLB software will be based on user access level.

2. Right-click on the VIN that you are connecting to, if present.

3. Select DELETE.
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4. Read the vehicle with DLB. Refer to Connecting to the Vehicle page 18 section.

Figure 145 Get Data Function

Figure 146 Get Data Function

5. Key ON.

6. Select GET DATA to ensure the module data that you are seeing is accurate.

Note which kernel is being displayed for the Six Position Switch-Packs.

• 23 or 17 or lower (kernel 23 is identical to kernel 17) - These kernels are subject to the
complaint of switch packs flipping or switches operating other features.

• 24 or higher
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Part Two – Check replacement part switch pack software that you will be installing in the vehicle (if
applicable).

1. Unplug switch pack 1.

2. Plug the replacement switch pack into the truck harness.

3. Leave the remaining switch packs unplugged. There will only be the single replacement switch pack
plugged into the truck harness.

4. Unplug the pigtail from the last switch pack and plug the pigtail of the replacement part back into the truck
harness (YELLOW and GREEN wires).

5. Connect with DLB and get the module data and check the kernel displayed to determine programming
path to follow.

• 23 or 17 or lower (Kernel 23 is identical to Kernel 17) - These kernels are subject to the
issue of switch packs flipping or switches operating other features.

• 24 or higher

Determine the Programming Path to Follow
Updating modules from Kernel 23 or 17 or lower (no

parts being replaced, or service part is also at
Kernel 23 or 17 or lower) page 133

Replacing switch pack - Existing truck switch packs
are at Kernel 23 or 17 (or lower). Replacement

part is at Kernel 24 (or higher) page 140

Replacing switch pack - Truck switch packs are
at Kernel 24 (or higher). Replacement part is at

Kernel 23 or 17 or lower page 148

Replacing switch pack - Existing truck switch packs
are at Kernel 24 (or higher). Replacement part

is at Kernel 24 (or higher) page 156

6. If you are adding a switch pack to a vehicle, follow one of the paths listed above. Instead of replacing
any parts, you will be adding an additional switch pack. That is, you will still need to determine the
Kernel in the switch pack you are adding to the vehicle, and the Kernel in the switch pack(s) currently
installed in the vehicle.

Overview of the Switch Pack Software Kernels
Switch Pack Software Kernel Concern Initial Corrective Software

17 or lower
Switch pack source address issue.
(Switch Packs flipping, switches

operating other features)
Kernel 22

22 Software bugs, VIN fault codes Kernel 24

23

Switch pack source address issue.
(Switch Packs flipping, switches

operating other features)

Kernel 23 replaced 22 and is
an exact copy of 17

Kernel 24
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1. Switch pack 1 with source address
151

2. Switch pack 2 with source address
152

3. Switch pack 3 with source address
153

Figure 147 Center Panel Tab Display

The DLB center panel tab displays switch locations.
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Repair Steps

Updating modules at kernel 23, or 17 or lower (no parts being replaced, or service part is also at
kernel 23 or 17 or lower).

1. If a switch pack is being replaced, move the switches over to the new switch pack, and plug the switch
pack into its proper location in the vehicle. All switch packs should now be functional, and all kernel
versions should be 23, or 17 or lower.

2. Key ON.

Figure 148 Switch Pack Programming

NOTE – Items and functions displayed in the tools menu will be based on user access level.

NOTE – The BCM may need to be updated before you can update the switch pack software. If a BCM
update is required, DLB will detect this and prompt you to exit switch pack programming and update
the BCM first. You will need to return to switch pack programming once the BCM has been updated. If
a BCM update is not required, DLB will continue with switch pack programming.
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3. Navigate to the Tools menu and select SWITCH PACK PROGRAMMING.

Figure 149 Unplugging Number One Switch Pack

NOTE – This step is not required if the vehicle is equipped with only one switch pack.

4. Unplug switch pack 1. This will force the switch packs to perform a source address claim.

Figure 150 Update Available

5. Select START to initiate programming.
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Figure 151 Status Bar

The status bar indicates the progress of switch pack programming. All switch packs will be programmed
automatically. Each switch pack will take approximately 5 1/2 minutes to complete.

135



PROGRAMMING A VEHICLE

Figure 152 Upgrade Complete Notification

You will be notified after the update is complete.

Figure 153 Functionality Check

NOTE – The functionality check allows the user to check operation of each switch pack. This will help
ensure that the switch packs were at the proper source address before programming was performed.

6. Select YES or NO in the functionality check prompt.

a. If you select Yes - Programming is now complete, no further action is required.

b. If you select No - A dialogue box opens for you to manually set the source addresses based on
the module serial number.
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Figure 154 Switch Pack Serial Number Menu
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Figure 155 Switch Pack Manual Programming

7. To manually set the source address, use the drop down menu to assign a switch pack serial number to the
proper source address. For each switch pack a drop-down displays all three serial numbers. Choose the
correct serial number for each location, and then select PROGRAM.
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Figure 156 Programming Complete

8. Programming is complete. Verify all switch packs are showing they have been updated to the latest kernel.

9. Verify one switch from each switch pack operates the correct feature as assigned.

139



PROGRAMMING A VEHICLE

Replacing switch pack - Truck switch packs are at kernel 23 or 17 or lower. Replacement part is
at kernel 24 or higher.

NOTE – All switch packs need to be at the same kernel in order to function properly. This section will
provide instructions on how to update the switch packs in the vehicle before installing the replacement
part.

You do not need the serial number of the faulty switch pack that is being replaced

1. Record the serial numbers of the switch packs in the vehicle, as well as the serial number for the new
switch pack that will be installed, and their location.

• Record the location (or source address) with the serial number together. Example: #1 - S/N
M20000000181011039, #2 - S/N M20000000181011040, #3 - S/N M2000000018101103941

To complete the upgrade and installation you will need to know the location and serial number to manually
set the source address using DLB.

The replacement switch pack will only display the last three digits of the serial number.

2. Key OFF.

3. Remove the faulty switch pack.

4. Any switch packs that are below the removed switch pack will need to be plugged in, so the daisy chain of
switch packs is not broken.

Example: Vehicle has four switch packs. Number two switch pack is being replaced.

• Remove switch pack 2.

• The switch pack 3 will need to be plugged into the switch pack 1 (All three remaining
switch packs are now plugged into each other - 1, 3, 4).

5. Key ON.
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Figure 157 Switch Pack Programming

NOTE – Items and functions displayed in the tools menu will be based on user access level.

NOTE – The BCM may need to be updated before you can update the switch pack software. If a BCM
update is required, DLB will detect this and prompt you to exit switch pack programming and update
the BCM first. You will need to return to switch pack programming once the BCM has been updated. If
a BCM update is not required, DLB will continue with switch pack programming.

6. Navigate to the Tools menu and select SWITCH PACK PROGRAMMING..
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Figure 158 Unplugging the Number One Switch Pack

NOTE – This step is not required if the vehicle is equipped with only one switch pack.

To start the programming process, you are asked to unplug switch pack 1. This will force the switch packs to
perform a source address claim.

Figure 159 Update Available

7. Select START to initiate programming.
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Figure 160 Status Bar

The status bar indicates programming progress while the switch packs program. All switch packs will be
programmed automatically. Each switch pack will take approximately 5 1/2 minutes to complete.
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Figure 161 Upgrade Complete Notification

You will be notified after the update is complete.

8. Select OK.

144



PROGRAMMING A VEHICLE

Figure 162 Programming Complete

Programming is complete. All switch packs are showing they have been updated to the latest kernel.

NOTE – Switch packs may be flashing red, and the replacement part may be non-responsive. This is
normal until you manually set the source address.

9. Key ON.

10. Navigate back to the Tools menu and select SWITCH PACK PROGRAMMING.
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Figure 163 Setting Source Addresses Manually

11. Select NO. This will allow you to manually set the source addresses.

Figure 164 Switch Pack Programming

Switch pack 1 was replaced. Only a partial serial number is displayed.

12. Set the switch pack source addresses based on their serial number and location in vehicle. Select
PROGRAM.
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Figure 165 Programming Complete

13. Source address programming is complete. Verify all switch packs are showing they have been updated to
the latest kernel.

14. Verify that one switch from each switch pack operates the correct feature as assigned.
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Replacing switch pack - Existing truck switch packs are at kernel 24 or higher. Replacement part is
at kernel 17 or 23 or lower.

NOTE – All switch packs need to be at the same kernel in order to function properly. This section will
provide instructions on how to update the switch packs in the vehicle before installing the replacement
part.

NOTE – You do not need the serial number of the faulty switch pack that is being replaced.

1. Record the serial numbers of the switch packs in the vehicle, as well as the serial number for the new
switch pack that will be installed, and their location.

• Record the location (or source address) with the serial number together. Example: #1 - S/N
M20000000181011039, #2 - S/N M20000000181011040, #3 - S/N M2000000018101103941

To complete the upgrade and installation you will need to know the location and serial number to manually set
the source address using DLB

The replacement switch pack will only display the last three digits of the serial number.

2. Key OFF.

3. Unplug switch pack 1.
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1. Switch pack pigtail plugged into
the data link going back to the IP
harness

2. Power ground and data link wiring
coming in from the IP harness

Figure 166 Single Switch Pack Plugged In

4. Plug the replacement switch pack into the number one location.

5. Unplug the switch pack pigtail of the last switch pack in the chain from the IP harness.

6. Plug the pigtail of the switch pack 1 into the connector going back to the IP harness. The replacement
switch pack, in the number one location is now the only switch pack plugged in. The in and out harness
should be plugged into the data link backbone.

7. Key ON.
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Figure 167 Switch Pack Programming

NOTE – The BCM may need to be updated before you can update the switch pack software. If a BCM
update is required, DLB will detect this and prompt you to exit switch pack programming and update
the BCM first. You will need to return to switch pack programming once the BCM has been updated. If
a BCM update is not required, DLB will continue with switch pack programming.

NOTE – Items and functions displayed in the tools menu will be based on user access level.

8. Navigate to the tools menu and select SWITCH PACK PROGRAMMING.
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Figure 168 Unplugging Number One Switch Pack

9. Unplug switch pack 1. This will force the switch packs to perform a source address claim.

10. Select OK.

Figure 169 Update Available

11. Select START to initiate programming.
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Figure 170 Status Bar

The status bar indicates programming progress while the switch pack programs. The switch pack will take
approximately 5 1/2 minutes to complete programming.
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Figure 171 Upgrade Complete Notification

After the update is complete, you will be notified.

NOTE – Switch packs may be flashing red, and the replacement part may be nonresponsive. This is
normal until you manually set the source address.

12. Key ON.

13. Navigate back to the Tools menu and select SWITCH PACK PROGRAMMING.

Figure 172 Setting Source Addresses Manually

14. Select NO. This will allow you to manually set the source addresses.
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Figure 173 Switch Pack Programming

Switch pack 1 was replaced. Only a partial serial number is displayed.

15. Set the switch pack source addresses based on their serial number and location in vehicle.

16. Select PROGRAM.
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Figure 174 Programming Complete

17. Source address programming is complete. Verify all switch packs are showing they have been updated to
the latest kernel.

18. Verify that one switch from each switch pack operates the correct feature as assigned.
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Replacing switch pack - Existing truck switch packs are at kernel 24 or higher - Replacement switch
pack is at kernel 24 or higher.

NOTE – Switch packs may be flashing red, and the replacement switch pack may be non-responsive.
This is normal until you manually set the source address.

1. Key ON.

2. Navigate back to the Tools menu and select SWITCH PACK PROGRAMMING.

Figure 175 Setting Source Addresses Manually

3. Select NO. This will allow you to manually set the source addresses.

Figure 176 Switch Pack Programming
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Switch pack 1 was replaced. Only a partial serial number is displayed.

4. Set the switch pack source addresses based on their serial number and location in vehicle.

5. Select PROGRAM.

Figure 177 Programming Complete

Source address programming is complete.

6. Verify that one switch from each switch pack operates the correct feature as assigned.

CLUSTER ODOMETER PROGRAMMING

The Diamond Logic® Builder software can be used to set the Odometer Value in the LCD display.

NOTE – Setting the Odometer is restricted to Dealer Level users only.
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1. In the menu bar, select Tools, then Set Odometer.

Figure 178 Tools Menu

The Set Odometer window appears.

Figure 179 Set Odometer Window

2. Read and follow the instructions in the Set Odometer window. Then, select the appropriate option for
setting the odometer.
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TIRE PRESSURE MONITORING SYSTEM (TPMS) PROGRAMMING

WARNING

To prevent personal injury and / or death, or damage to property, before swapping wheels
to different locations, use DLB to identify the current configuration. Make note of the
pressure sensor serial numbers assigned to each location. Use DLB to program the
sensors to the correct locations, if wheels are moved to different locations.

WARNING

To prevent personal injury and / or death, or damage to property, always follow these
instructions when mounting tires on wheels. Only personnel who have had proper
training and experience should mount or remove tires from rims or wheels. Use only
heavy-duty rims or approved rims for radial tires. It may be necessary to contact your
wheel and rim distributor to determine if your rims are approved for radial tires. If a
tube is to be used, make sure that special radial tire tubes are used because of the
increased flexing of the sidewalls on radial tires. Never use antifreeze, silicones, or
petroleum-based lubricants when mounting radial tires. Only an approved lubricant
should be used as an aid for mounting tires. Always inflate tires in a safety cage.

WARNING

To prevent personal injury and / or death, or damage to property, do not mix stud-piloted
wheels or fasteners with hub-piloted wheels or fasteners. Mixing wheel types may cause
premature wheel failure. Do not change from steel wheels or a steel inner and aluminum
outer wheel combination, to aluminumwheels, without changing themounting hardware,
since the thicker aluminum wheels require longer studs. In some cases, with flange nut
mounting systems, changing the hub and stud assembly may be required. Improperly
mixing components could cause wheel or fastener failures. Do not mix foreign (not
made in North America) wheel mounting parts with domestic (made in North America)
parts. Many foreign wheel components look similar to, but are not exactly the same as,
domestic made components.

CAUTION

To prevent damage to property or components, when mounting and dismounting a tire,
take care not to damage the pressure sensor that is strapped to the inner rim. If tire work
is done at another facility, please let them know that a tire pressure monitoring system
is installed on the vehicle, before they remove a tire from a wheel.

System Overview

Tire Pressure Monitoring System (TPMS) provides warnings when the tire pressure is out of the desired range
or the tire temperature is too high. Feature codes are 16VLS,16VUY,16VVA, and 16VUZ . The system monitors
the temperature compensated and the tire pressure of each wheel. Tire pressure information is displayed in
the LCD for 4 x 2, 6 x 4, and Super Single axle configurations. The system does not Include monitoring for
lift axles, spare wheels, or trailer wheels. All system programming is accomplished using the Tire Pressure
Monitoring System (TPMS) Programming selection, found in the Tool Menu in the DLB software.
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1. Front receiver module
2. Rear secondary receiver module
3. Wheel sensor

4. Wheel sensor
5. Wheel sensor

Figure 180 TPMS Location Overview
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Figure 181 Installed Wheel Sensor

The system uses two receiver modules. The front receiver is hard wired to the truck data link. The second
receiver communicates via wireless, using a 433 MHZ signal, to the front receiver. A wheel sensor is installed
on each wheel rim.

CONNECTING TPMS MODULE WITH DLB

Figure 182 TPMS Module Display in DLB

Use DLB to connect to the vehicle, with the key ON. The TPMS will only power up when the key is ON. The
TPMS module should be detected as shown above.
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TPMS PROGRAMMING AND MONITORING

Figure 183 Tools Menu

When the TPMS is detected and the Tools tab is selected, the TPMS programming option will be displayed
as shown above.
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Figure 184 TPMS Sensor Display

NOTE – It may take up to 5 minutes for all sensors to be read.

The graphic shown above shows what will be displayed after clicking on TPMS Programming. This screen
provides the interface to monitor the system, adjust and program parameter changes, and pair new receivers.

The Program button will program any changes that are made.

The Reset buttons will revert any changes that are made before programming any changes.

The Pair button is used to pair the rear receiver to the front receiver.
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Figure 185 TPMS Axle Configuration 4x2

Figure 186 TPMS Axle Configuration 4x6

Figure 187 TPMS Axle Configuration 4x6
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The vehicle configuration is determined by the number of axles and wheels that are programmed as shown
in the examples above.

Figure 188 Measurement System

Selecting Units from the View menu in DLB changes the units shown in TPMS programming..
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Figure 189 Metric Measurement Display

The graphic above is an example of how the Metric selection appears.

Figure 190 TPMS Wheel Sensor and Axle Configuration

The graphic above shows the axle configuration and status of each wheel sensor that is installed.
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Figure 191 Legend

Clicking on Legend displays an explanation of the different states of the tires.

Figure 192 Selected Tire Status

Click on the desired wheel to make changes to the Sensor ID at that location or the axle associated with that
wheel. The graphic above shows the status of the selected wheel.

Changing the eight-character wheel sensor ID will change the sensor that is associated with the selected wheel.
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Figure 193 Wheel Sensor ID

The wheel sensor ID is printed on a label that is attached to each sensor.

Setting the eight-character wheel sensor ID to 00000000 will remove any sensor correlation to that wheel.
This can be used to remove the sensors, if the configuration is changed due to removal of an axle or setting
the tire configuration for super singles.

Clicking on the Program button will program any changes that are made.

Figure 194 Tire Pressure Values Per Axle

The graphic above shows the programmed tire pressure that is desired, on the selected axle. It also shows the
desired pressure percentages for the low pressure and extreme low pressure conditions.
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Figure 195 Tire Pressure Desired Values

Changing the value for one wheel, on an axle, will change the values for all wheels on the axle. The low
pressure parameter is not adjustable. It is set for 125% of the Nominal Pressure. To adjust the desired values,
make a change and then program. Clicking on the value will cause a drop down to appear.

Select the desired value.

The Program button will program any changes that are made.
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Figure 196 Undetected Wheel Sensor Output Values

A tire sensor that is not being detected will display the values, as shown above.
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Figure 197 TPMS Programming

The outlined BLUE wheel indicates changes were made to the sensor ID numbers and the wheel is waiting to
be programmed.

Several changes can be made prior to committing them by programming. It also shows the progress bar
that is displayed during the programming process.
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Figure 198 Under-Pressure Tire Condition

The graphic, shown above, includes the indication that a selected tire has an under-pressure condition.
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Figure 199 Extreme Under-pressure Tire Condition

The graphic above indicates that a selected tire has an extreme under-pressure condition.

Figure 200 TPMS High Temperature Threshold and TPMS Receiver One and Two Information
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The graphic above shows the setting for the High Temperature Threshold and the information for both TPMS
receivers. The user will be able to adjust the desired values and pair the secondary wireless receiver.

Figure 201 TPMS High Temperature Threshold Desired Values

Clicking on the value will cause a dropdown to appear.

Click on the desired value, then select Program. Changing the value will set the temperature threshold
for all tires, on both receivers. All trucks will have two receivers. The first one is connected to the Body
Builder data link and the second one communicates, via wirelessly, to the first one. The first receiver can
handle up to 3 axles. If the second receiver fails, the first one can monitor data for the first 3 axles. When
the secondary, wireless, receiver is replaced, it will need to be paired. Pairing must be requested within 10
minutes of a key cycle.

Select the Pair button to start the pairing process.
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Figure 202 Pairing Process Bar

The graphic shows the progress bar that is displayed during the pairing process. When the first receiver is
replaced all the values for the wheel sensors, tire pressures and temperatures will need to be reprogrammed.

Replacement of the secondary receiver does not require programming after it is paired.
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Figure 203 Sensor Programming

NOTE – Open a case file to see if Tech Services can provide the sensor IDs that were used when the
truck was built. If they cannot be provided, each tire will need to be removed to find the sensor ID.

The graphic above shows a receiver that has been paired but does not have any wheel sensors programmed.

Replacement of the secondary receiver does not require programming after it is paired. When the first
receiver is replaced, all the values for the wheel sensors, tire pressures, and temperatures will need to be
reprogrammed.

If the axle or wheel configuration is modified, the changes will need to be programmed in the TPMS system.
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TPMS PROGRAMMING FOR CLUSTER DISPLAY

Figure 204 TPMS Cluster Display Feature Codes

If the tire or axle configuration is changed, the Body Control Module (BCM) feature will also need to be
changed to match the new configuration.
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DIAGNOSING ELECTRICAL PROBLEMS WITH DIAMOND LOGIC®

BUILDER
The Diamond Logic® Builder software can be used to aid in diagnosing and troubleshooting electrical / electronic
system problems. Before proceeding with diagnosing and troubleshooting, there are several important steps:

• Verify the Problem – Operate the complete system and list all symptoms. Is the complaint
due to misunderstood, customer-selected, programmed parameters?

• Gather Information – What happened and when? Under what conditions? When did the
symptoms begin? What else occurred at the time?

• Check Diagnostic Trouble Codes – Do the logged codes correlate to the symptoms and
probable causes? Were the codes logged repeatedly?

• Perform Preliminary Checks – Perform a thorough visual inspection. Are any wires loose
or corroded? Are there damaged connectors or pins? Are all components installed and
installed correctly? Check to make sure the vehicle batteries are at 75% state of charge or
higher. Make sure indicator lights are not simply burned out.

• Check References – Check all relevant service information including circuit diagrams and diagnostic charts.

ENTERING DIAGNOSTIC MODE

When diagnosing a vehicle using the Diamond Logic® Builder software, the first step is to connect the
system to the vehicle:

Figure 205 Tab

1. On the tab, the vehicle to be diagnosed.

Figure 206 Computer Link Icon

2. In the toolbar, click the Computer Link icon.
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3. Verify that the connection is established by checking the icon in the lower-right corner of the window. This
icon should show that the vehicle is connected.

Figure 207 Computer Link Icon, Connected

NOTE – When in Diagnostic Mode the gauge cluster will act erratic. This is normal.

4. In the toolbar, click the Diagnostic Mode icon.

Figure 208 Diagnostic Mode Icon

Figure 209 Diagnostic Mode Icon, ON

When Diagnostic Mode is ON, the icon appears indented in the toolbar.
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USING THE SIGNALS TAB TO DIAGNOSE ISSUES

When the Diagnostic Mode is started, an extra data column is added to the Signals tab and the Advanced
Logic tab. This column is labeled Lock. The Watch and Lock columns are essential in performing diagnostic
troubleshooting. The Watch Column appears as a closed eyelid. Single clicking on the closed eyelid changes
it to an open eye. This enables the signal for diagnosis in real time. The value of the signal may be viewed in
the Value column.

If any of these columns are not visible:

1. Right-click on any of the column headings. This produces a menu that lists all the columns that
may be displayed in the table.

2. Ensure that the Custom Signal, Signal, Pins, Value, Unit, Status, Watch, and Lock columns are
turned on (checked) as a minimum. If desired, other columns may be checked as well.

Figure 210 Signals Tab with Columns Appropriate for Diagnostics
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Using Make Session to Select WATCHED Signals

Clicking Make Session on the Features tab will open a Signals tab session that displays the signals related
to the selected feature.

1. Select the Features tab.

Figure 211 Features Tab

2. Select (click) the feature whose signals you want to watch.

3. Click Make Session to open the Signals tab with the Watched sub-tab selected. The signals that apply
to the selected feature will be listed.
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Figure 212 Watched Sub-Tab

4. If desired, add additional signals by doing the following:

a. Select the ESC Signals sub-tab.

b. Click the eye icon for each additional signal you want to watch.
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Using Signal Status while Diagnosing

Each signal in the Diamond Logic® electrical system has an associated Status or health. A Status value of
zero indicates a good signal status. Any other value for status indicates that the signal health is bad and will
not be used by the program logic. When troubleshooting, it is essential that the user inspect the Status of
system signals being tested to ensure that they have a value of zero. If any of the values are greater than
zero, then go to the Faults tab and look for diagnostic trouble codes.

NOTE – Many signals that have bad status, such as the HVAC thermistors, no longer have related fault
codes.

To quickly find signals that the user wishes to watch:

1. On the Signals tab or the My Variable panel of the Advanced Logic tab, click the Filter button on the
left end of the table heading.

Figure 213 Find Window

2. Enter the word or words to search for.

3. Click OK.

By observing the data in the Value column, the user can monitor the value of selected signals. ON / OFF
signals are represented by a check box where the signal is ON when the box is checked. Also observe the
Unit column to see the unit of measure associated with the signal value.

Figure 214 Observe the Value and Unit Columns
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Forcing Signal Values

In addition to monitoring signal values, the user can also force signals to a predetermined value. For example,
the Accessory signal can be forced ON or OFF just by checking or unchecking the box in the value column
on the Accessory line. The accessory voltage is not actually being forced ON or OFF, but from an ESC
/ BC programming logic standpoint it is. Therefore, all the features or Advanced Ladder Logic that use the
Accessory signal will respond according to the ON / OFF state of Accessory.

Once a signal is forced to a new value, the Lock icon in the lock column will show as locked. When locked,
changes by external inputs such as switches or sensors will be ignored.

To restore the signal to an unlocked condition, click on the Lock icon; now the signal will respond to normal
system inputs and outputs. Alternately, unlock all locks by taking the DLB software out of Diagnostic Mode.
You will have to return to Diagnostic Mode to continue diagnosing.
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Signals and Custom Logic

It is also possible to examine Custom Signals and Ladder Logic on the Signals tab. An example is shown in
the figure below.

Figure 215 Custom Values and Ladder Logic
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In the first Ladder Logic rung, there is SW_1 and a Park_brake; SW_1 is off as indicated in the grayed area. In
the signal listing, clicking the SW_1 Value check box turns on the switch.

Figure 216 SW_1 Switch is ON
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USING THE CONNECTORS TAB TO DIAGNOSE ISSUES

Signal values that are present on physical pins of various electrical modules can be observed by selecting the
Connectors tab. Note that there is a tab for each module. Use the connector view to help isolate the problem.
The connector views provide the ability to monitor system values without the use of breakout boxes. Scaled
voltages, temperatures, and pressures are presented for analog voltages and checkboxes are provided for
ON / OFF values.

Figure 217 Connectors Tab

On the Connectors tab, you can observe the state of each input and output from the ESC / BC and each RPM
and MSVA. You can also override each input and output.
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To view individual inputs and outputs:

1. Select the sub-tab for the module that you wish to view. The sub-tab displays an image of the
module and its connectors on the left.

2. Select a connector in the image on the left by clicking on it. The selected connector becomes
shaded in gray and is displayed on the right.

Figure 218 Selected Connector Displayed on Right
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RPM Output Connector View

The figure below shows the output connector for RPM 1. To select an output, click on its name. The selected
name and the corresponding pin in the connector drawing will appear highlighted in YELLOW. Selecting an
output in this way will also automatically select this output in the Signals tab. This is very helpful if you are not
sure of the feature code that controls a particular RPM output. To turn off the YELLOW highlight, hold down
the Ctrl key while selecting an output.

Figure 219 RPM Output Connector View, Outputs on Right (Typical)

Several pieces of information are displayed for each output: (Refer to figure above for numbered items.)

Item Description

1 Cavity pin numbers (shown in brackets)

2 Entering a voltage here sets the value of this output to the entered value.

3

The lock icon is used to lock and unlock the output to the value entered to the left (Item 2). When
locked, no other signal can drive that output. (When unlocked, a blank space appears here. Click
the blank space to lock the output.)

NOTE – If you are having trouble with outputs not turning ON or OFF as expected, check to
make sure those outputs are unlocked.

4 The current level (in Amps) that this output must reach in order to trigger the virtual fuse configured
for this output. The default is 20.

5

The name assigned by the feature that is using this output.

NOTE – A bold output name would indicate that a custom name has been assigned to this
signal by advanced logic.
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Information about the outputs on the left of the connector are displayed in roughly the opposite order.

Figure 220 RPM Output Connector View, Outputs on Left (Typical)

RPM Input Connector View

Input connectors, like the example shown below, are represented in a similar manner as output connectors,
with some minor differences.

Figure 221 RPM Input Connector View (Typical)

Each pin of an input connector can be programmed in the ESC / BC to respond to either a 12V signal or
a ground signal.

The lock works the same as it does on the output connector.

The input connector will also show the addressing; note the jumper wire between pins 1 and 2. Jumper wires
on the input connector determine how an RPM is addressed. Addressing is extremely important. RPM
input connectors should not be moved around. Doing so will move all inputs and outputs programmed
to that particular RPM.
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DIAGNOSTICS ON THE ADVANCED LOGIC TAB

Diagnostics Sub-Tab

The Diagnostics sub-tab allows the Advanced Logic writer to provide information regarding the advanced
logic. If such documentation has been provided on this sub-tab, it may contain valuable information for
diagnosing the advanced logic.

Ladder Logic Sub-Tab

Diagnostics in the ladder view are simple and straightforward:

1. Connect to the truck.

2. Enter Diagnostics Mode.

3. Select the Advanced Logic tab. On this tab, GRAY OFF or BROWN question mark shadow blocks will
be seen over most items. BROWN shadow blocks indicate items that the present state cannot be
determined. On the right of the window, you will see the tabs that contain all the signals that can be
used in advanced logic.

4. At this point, you can observe actual signals received from the truck.

For example: while hooked up to the vehicle, in Diagnostic Mode and on the Advanced tab, you can observe
the actions on the vehicle. The figure below (Figure 222) shows an advanced block with a switch in the first
rung of the ladder logic. There are two ways of testing to ensure the vehicle is working properly. The first is to
actually activate the switch in the vehicle and watch for the outcome on the screen. The second is to override
the switch and click the checkbox in the value column on the right of the screen. Clicking the checkbox is the
way to test out the advanced logic in the simulate mode. This tells the ESC / BC to ignore the switch state
and activate the circuit regardless of switch location.

Figure 222 Advanced Logic Block with a Switch in the First Rung
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The next figure shows the same view with the switch in the up position. Notice on the left side of the window,
the graphic display shows that the switch and corresponding outputs are now in the ON position. The right side
of the screen now has checkmarks in the items that have been set to ON. Returning the switch to the OFF
position will once again turn OFF the switch and the switch outputs.

Figure 223 Switch in First Run is Now ON

Each of these techniques has value. For items such as switches and the park brake, it is very easy to either
turn them ON or OFF. However, for items such as intermediate variables created in the ladder logic and RPM
input signals, the value column is an excellent option. This overrides the vehicle signal. By observing the
reaction of the logic rung, you can diagnose the vehicle. If all the items on the left side of the logic block are
properly set, the value on the right should be either ON or OFF. If the contact, light, or output indicator is on in
the Diagnostics tab, then the output should also be on; if not, check for a fault code in the Faults tab.
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DIAGNOSTICS ON THE CENTER PANEL TAB

In Diagnostics Mode, the Center Panel tab displays images of the switches. A YELLOW line represents the
multiplex data link tying the switch packs together. Arrows indicate the current switch setting of each switch.
When the state of the actual switch is changed, the arrows and images will change and indicate the new state.

Diamond Logic® Builder can override switches.

When Diamond Logic® Builder is used to cycle switches, the arrows and images will change, indicating the new
state. Additionally, the padlock icon will appear, indicating a locked condition.

Figure 224 Center Panel Tab
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To override a switch, either left-click on the desired switch setting or right-click on the switch and select a
desired setting from the right-click menu.

Figure 225 Switch Right-Click Menu

Clicking the top portion of the switch will activate that switch output and the arrow will move to the up position.
This overrides the switch and allows you to determine if there is a switch problem.

Figure 226 Switch in ON Position, with Lock

The padlock, which appears on a switch, allows you to lock that signal in any of the switch’s valid positions.
Click on the lock to remove it.

When diagnosing switches, it is important to remember a few facts:

• The switch rocker is nothing more than a pair of plungers. When a switch is pushed, it pushes
one of the two plungers in and contacts a micro switch in the switch pack.

• Each switch location has two micro switches. The switch can be in 1 of 3 valid states; micro switch
1 is depressed, micro switch 2 is depressed, or neither micro switch is depressed.

• When diagnosing a switch by checking the box in the Signals tab, the Features tab, or the Advanced Logic
tab (while in either Diagnostic Mode or Simulate Mode), you must select the switch position you want, such
as the switch up position. You must also make sure that the switch middle and switch down boxes are not
checked. If you have more than one switch state selected in the Advanced Logic tab or the Signals tab, your
switch will show yellow in the Center Panel tab. This tells you that you have put the switch in an illegal state.

• Turn OFF or unlock the individual switch signals in the Signals tab before you continue
with diagnostics or simulation with the Center Panel tab.
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DIAGNOSTICS IN THE CLUSTER TAB

When the Cluster tab is selected in Diagnostic Mode, the movement of the gauges mirrors the movements of
the actual gauges. For example, if the fuel gauge does not appear to be working, you can check the gauge
cluster view and see if the signal is driving the Diagnostic Mode gauge. If the gauge in the Diagnostic Mode is
working, but the actual gauge is not, follow the Navistar troubleshooting guide to complete the diagnosis.

By placing the cursor on the outer ring of a gauge and clicking the left mouse button, the user can override the
actual gauge signal. This forces the gauge to the reading indicated by the cursor location. In the illustration
below, the tachometer has been clicked at the 1300 RPM mark.

Figure 227 Cluster Tab

When observing the gauges in Diagnostic Mode, a gauge may momentarily dip to 0. This occurs because of
the high update rate required by some gauges and an update may occasionally be missed. The speedometer
and the tachometer are most susceptible to this anomaly because of their high update requirements. This is a
normal condition and is not an indication of a defective gauge.
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Double-clicking in an area around the center of a gauge will bring up a text box in which a specific gauge set
value can be entered. The gauge should follow the diagnostic gauge setting. If the gauge does not follow
the diagnostic gauge, then follow the Navistar troubleshooting guide.

Figure 228 Temperature Gauge Double-Click Box
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DIAGNOSING AND CLEARING FAULT CODES

When DLB is in Diagnostic Mode, it will display fault codes generated by most modules communicating
on the J1939 (CAN) Data Link.

Figure 229 Diagnostic Mode Icon

To enter Diagnostic Mode, click the Diagnostic Mode icon in the toolbar.

Erasing Faults

Figure 230 Clear Faults Icon

To erase faults:

1. Click the Clear Faults icon in the toolbar. A window like the one shown below will appear.

Figure 231 Select Modules Window

2. Check the box next to each module that you wish to clear faults from.

3. Click OK to clear the faults from the selected modules.

If fault codes are still active, they will repopulate the Faults tab.
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Decoding Diagnostic Fault Codes

The user can decode diagnostic fault codes directly by selecting the Faults tab.

Figure 232 The Faults Tab

The Faults tab provides a very comprehensive description of a diagnostic fault for the BCM / ESC including
text description, probable cause, connector pin associated with the fault, and the module associated with the
fault. Note these faults are only associated with modules communicating on the J1939 (CAN) Data link.

Tips

• Diagnostic fault codes will only be viewable on the Faults tab while the ignition key is in the run
position. The engine does not need to be running to view the ESC / BC codes.

• Diagnostic programs provided by the power train component suppliers can still be
used to diagnose those systems.

• For all vehicles, the Diamond Logic® Builder program will show fault codes from the BCM.
For more recent vehicle models, DLB may also show fault codes from the instrument cluster,
from the door pod, and from the LCM. Diagnostic programs provided by the power train
component suppliers can still be used to diagnose those systems.

• When diagnosing the gauge cluster with the Diamond Logic® Builder program, the pointers may
not be stable. The pointers may be steered to 0 intermittently. This is normal. Do not replace
the gauge cluster due to this anomaly. It is important that the user can steer the gauge to a
nominal value and that the pointer does not stick or jump in the process.
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Module Detection

The Diamond Logic® Builder program has a module detection function. The purpose of this function is to
provide a quick look at which electrical system modules are communicating on a data link or should be
communicating on a data link. Selecting the Detected Modules sub-tab will display the modules that are
communicating on the Drivetrain J1939 Data Link. Selecting the Inferred Modules sub-tab will display all
modules that are expected to be present in the configuration of the vehicle but are not communicating.

Figure 233 Inferred Modules

Modules that do not communicate on the Power Train J1939 Data Link (but do communicate on one of the
other data links) will have a blank in the detected column. Currently the system accurately detects modules
that are connected to the power train J1939 Data Link.

Modules that are not, but should be, communicating on the Power Train J1939 Data Link will have an X icon in
the detected column. See the Inferred Modules figure above (Figure 233).
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USING SESSIONS AND TRIGGERS
The session function allows a user to save a custom group of signal selections to an electronic file, which can
be used in the future. This allows the user to quickly select a set of signals to use during diagnostics. Sessions
can only be used in Diagnostic Mode. Selected signals and trigger settings are also saved in the session.

NOTE – Creating and saving sessions is not recommended. Clicking Make Session while viewing the
Features tab will open a signal session displaying the signals related to that feature. This should meet
most of your Signal Session requirements.

OPENING A SESSION

If you have previously saved any sessions, you can reopen them. To open a session:

1. In the menu bar, select Diagnostics > Open Session.

Figure 234 Opening a Session

A window that prompts the user for the location and filename of the desired session appears.

2. Select the session file to be loaded.

After a session has been loaded, the session’s signals can be viewed on the Signals tab. Select the ESC
Signals sub-tab to view all signals in the vehicle configuration that are present in Navistar®-designed features
on the vehicle. Select the Watched sub-tab to see a listing of signals used in the selected session.
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CREATING A SESSION

Creating and saving sessions is not recommended. It is better for most users to click the Make Session button
on the Features tab. This opens a signal session that displays the signals related to the selected feature.
Refer to Using Make Session to Select Watched Signals (page 181). This should meet most of your session
requirements. The following information is provided for advanced users who might need to use the Graphing
and Trigger functionality in DLB.

To create a session:

1. In the menu bar, select Diagnostics > New Session.

Figure 235 Creating a New Session

2. Select the Signals tab.

3. Select the sub-tab that lists the signals to be watched:

• The ESC Signals sub-tab lists all signals in the vehicle configuration that are present
in Navistar®-designed features on the vehicle.

• The Custom sub-tab lists all ladder logic signals that have been created in Advanced Logic.

• The Master List sub-tab lists all possible signals in the Diamond Logic® electrical system. Note that
the vehicle being diagnosed will only have a small subset of the Master List of signals.

4. In the chosen sub-tab, use the search utility to find the signals to graph or record.
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5. Enable each signal to be watched by clicking the eyelid icon next to the desired signal. When the eyelid
changes to an open eye, the signal is selected.

6. Select the Watched sub-tab to see the list of all selected signals. Verify that all desired signals are
listed. In the figure below, BC_RCD_Tempt_In_Raw_Signal, BC_RCD_Temp_Out_Raw_Signal, and
Switched_5V_Sense_Raw_Signal have been selected.

Figure 236 Selected Signals on the Watched Sub-Tab

7. In the menu bar, select Diagnostics > Save Session. The Save Session window appears.

Figure 237 The Save Session Window
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8. Navigate to the folder in which this session should be saved and enter a filename for this session. The
example above uses the name 3h365533.

9. Click Save.

The signals chosen to watch can be retrieved as a session file with the name entered. All session files are
given the .dls file name extension. For example, the full name of the file whose name is being entered in
the figure above will be 3h365533.dls.

In addition, this file can be sent by email.
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SELECTING SIGNALS FOR RECORDING AND GRAPHING

In this example, we will watch two switches set up in custom logic and the associated indicators for the switches.

1. Select the Signals tab and then the ESC Signals sub-tab.

Figure 238 ESC Signals Sub-Tab

2. Click the Custom Signal heading to move custom signals to the top of the list.

Figure 239 Not Watched Icon

3. Select each signal to be watched by clicking the Not Watched icon for each desired signal.

Figure 240 Watched Icon

The icons will change to indicate that the corresponding signals are now Watched.

Figure 241 Watched Sub-Tab

4. Select the Watched sub-tab. Verify that the desired signals are now listed here.

5. Select the Graph sub-tab.
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Figure 242 Recorder Icon

6. Click the Recorder icon in the toolbar.

NOTE – The Recorder icon can be selected only while DLB is in Diagnostic Mode. Therefore,
graphing can be performed only while DLB is in this mode.

Figure 243 Diagnostic Mode Icon

7. Click the Diagnostic Mode icon in the toolbar to enter Diagnostic Mode.

NOTE – DLB will not switch to Diagnostic Mode unless it is connected to a vehicle and
communicating with the ESC / BC.
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The graph below shows the results of turning ON Switch 1 and Switch 2 then turning OFF Switch 2 and
Switch 1.

Figure 244 Graph Showing Switches Being Turned ON and OFF

The Recorder icon in the toolbar both starts and stops the recording of data to the graph. Additionally, it arms
the triggers. If no triggers have been set, recording to the graph continues until the user stops it by clicking the
Recorder icon again. If there are triggers set, the user can still manually stop the recording by clicking this icon.

Recording and Graphing Views

The Graph sub-tab shows data formatted in specific scaled data views, such as volts, pressure, or digital ON /
OFF signals shown as a 1 or a 0. The graphing area is divided into as many views as are required to display
all the data types. Therefore, it is desirable to keep the number of signal types watched to three or less.
All signals of a given data type will be displayed on the same graph. Therefore, the user should minimize
the number of signals that are watched on any single graph. The graphical recorder is able to record a
single new data point every 50 milliseconds (0.050 seconds). Therefore, it is important to minimize the total
number of signals watched to less than 10 to maintain a close representation of the real time graphing of the
signals. Watching more than 10 signals will result in possible missed signal transitions on the graph, plus
the graph will be hard to read.
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USING THE TRIGGER FUNCTION

Triggers are used to detect a condition and mark it on the graph. Triggers can also stop the recording on the
graph after a specified amount of time so the trigger condition does not get lost. If you kept recording forever
the trigger would be lost 10 minutes after it fires because DLB will only keep a maximum of 10 minutes of
data. The recorder must be started to begin the trigger process. The system will begin recording even though
the trigger event may not have occurred yet. When the trigger does occur, the graph will be marked with a
start line. The recording will continue until the selected amount of time has elapsed, the graph is stopped
manually, or the maximum recording time has expired.

Setting Up a Trigger

In the menu bar, select Diagnostics > Edit Triggers. The Edit Triggers window appears.

Figure 245 The Edit Triggers Window

The drop-down menu in the upper-left of this window allows you to choose the category of signal to view.
Once a category is selected, use the drop-down menu in the upper-right to choose the individual signal to
use as a trigger. The trigger can be set up to detect when the signal goes active (Rising Edge), when the
signal goes inactive (Falling Edge), or when it reaches a specific value. The trigger may be delayed until the
occurrence (Fault) has occurred after a specified number of counts. Finally, the trigger may be set to stop
recording after a specified time.
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Figure 246 Trigger Example

Once a signal is selected, the trigger may be set to fire when a specified value has been detected. The
example above shows that a trigger has been set to fire when the Door_Switch signal turns ON. The trigger will
stop recording 30 seconds after the trigger event occurs.

Saving and Viewing the Graph

The graphed data can be saved in a file that can be read with Microsoft Excel or reopened in DLB for future
reference. To save the graph data:

1. In the menu bar, select Diagnostics > Save Graph Data. A window will open prompting you to name
the file and select a location for saving the file.
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Figure 247 Saving Graph Data

2. In the File name box, enter a name for the saved data file. (Graph data is saved as a .csv file, which is a
plain text file containing comma separated values.)

3. Click Save.

A saved graph file can be reopened with DLB by selecting Diagnostics > Open Graph Data in the menu bar. A
window will open prompting you to select the file to be viewed.
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CLOSING THE DIAMOND LOGIC® BUILDER PROGRAM
Follow these steps to close the Diamond Logic® Builder program:

1. If connected to a vehicle, disconnect the link by clicking the Communications Link icon in the toolbar.

Figure 248 Communications Link Icon — Connected

The image for this icon on the toolbar should now show a disconnected state. A similar icon will appear in
the lower right corner of the window.

Figure 249 Communications Link Icon — Disconnected

2. Close the DLB program window. There are two ways to do this:

• Click the Close button (X) in the upper-right corner of the window.

• In the menu bar, select File > Close.

Either option will end the session.
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UNINSTALLING THE DIAMOND LOGIC® BUILDER SOFTWARE
Follow these steps to remove the DLB software from a computer:

1. If the product key used for DLB on this computer will be used to install DLB on another computer,
unregister this computer by selecting Help > Registration > Unregister this Machine in the menu bar.
This releases the key for use on another computer.

2. In the Windows Start menu, select All Programs > Diamond Logic Builder > Uninstall.

Figure 250 DLB Uninstall in Windows Start Menu

If Uninstall does not appear in the Start menu, use the Add or Remove Programs option in the Windows
operating system to remove Diamond Logic® Builder.
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DLB SUPPORT FOR CF 500, CF 600 AND CITYSTAR® TRUCKS
DLB can be used to set the Odometer Value within the cluster and can drive the J1939 driven gauges
(Speedometer, Tachometer, and Coolant Temperature Gauge). It cannot turn on warning lights or indicators,
nor can it exercise the fuel gauge.

Connect the interface cable to the diagnostic connector. A connection status bar should start to scroll across
the bottom of the DLB display.

Figure 251 Select Tab (Lower Portion)

After the vehicle information has been downloaded, select LCF in the list to display LCF information on
the lower right portion of the Select tab.
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TESTING GAUGES

To test the gauges:

1. Click the Diagnostic Mode icon.

Figure 252 Diagnostic Mode Icon

2. Select the LCF Instrument Panel tab. The LCF cluster will be displayed.

Figure 253 LCF Instrument Panel Tab

3. Gauges with RED dial indicators can be tested by clicking and dragging the indicator.
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DLB SUPPORT FOR THE VEHICLE INFORMATION DISPLAY (VID)
The DLB software must be used to program parameters that are not available on the VID on-screen menus.
Other parameters can also be configured with DLB.

Module Selection

Connect DLB to the vehicle as you normally would. Driver Display should be listed in the Module field under
the Detected Modules tab.

NOTE – You may need to pull fuses to prevent other components from communicating on the data link
so DLB will connect to the VID successfully.

On the Select tab, select the Driver Display serial number under Detected Modules.

Figure 254 Select Tab with Driver Display Serial Number Selected
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Features

The Driver Display tab can be viewed only when a Driver Display or a VID Template is selected.

Figure 255 Driver Display Sub-Tab

Programming

Select the parameter and change it as desired. Use the Program Module option to program the VID only.
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DOS AND DON’TS

DOS AND DON’TS
Do

• Test all designs thoroughly before selling equipment controlled by Diamond Logic® Builder
programming. Exercise inputs and outputs under ALL possible combinations and conditions.
Someone in addition to the advanced logic writer should test the design on the vehicle with the
equipment that is to be controlled with the Diamond Logic® Builder software.

Don’t

• Do not try to program a vehicle with the ignition key OFF. Ensure the dome lights or park lights are on
and the battery voltage is between 12.5 and 14 volts. Connect to a charger if necessary.

Information

• The user ID is attached to each VIN configuration file when the user programs a vehicle. Adding / deleting
features or changing programmable parameters is the user’s responsibility. Navistar, Inc. shall not be
liable for any consequential warranty or equipment damage resulting from the users programming efforts.

• Diagnostic fault codes will be viewable on the Faults tab only while the ignition key is in the Run
position. The engine does not need to be running to view the ESC / BC codes.

• Diamond Logic® Builder will show fault codes from most modules communicating on the
J1939 (CAN) Data Link. Diagnostic programs provided by the power train component
suppliers can still be used to diagnose their systems.

• When diagnosing the gauge cluster with Diamond Logic® Builder, the pointers may not be stable.
The pointers may be steered to zero intermittently. This is normal. Do not replace the gauge
cluster due to this anomaly. It is important that the user can steer the gauge to a nominal
value and that the pointer does not stick or jump in the process.
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ACRONYMS

ACRONYMS
ABS – Antilock brake system

AMP – Ampere

ATC – Automatic Traction Control

BCM – Body Control Module (Replaces ESC in most 2007+ vehicles)

BOC – Back of Cab

DLB – Diamond Logic® Builder

EGC – Electronic Gauge Cluster

ELAM – Electronic Lift Axle Module

ESC – Electronic System Controller

FET – Field Effect Transistor

FR – Front

GA – Gauge

GND – Ground

HVAC – Heating, Ventilation and Air Conditioning

HYD – Hydraulic

I/O – Input / Output

IGN – Ignition

MSVA – Modular Solenoid Valve Assembly (also known as RATM in other areas)

OnCommand® Service Information– Trademark for Navistar’s website that provides service and diagnostics
information.

PDC – Power Distribution Center

RAM – Random Access Memory

RASM – Remote Air Solenoid Module
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ACRONYMS

ROF – Rear of Frame

RPM – Remote Power Module

RR – Rear

SW – Switch

TPMS – Tire Pressure Monitoring System

VIN – Vehicle Identification Number

VSS – Vehicle Speed Sensor
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CONTACT INFORMATION

CONTACT INFORMATION
Navistar, Inc. maintains a customer service technical support line for assistance with Advanced Logic and
programming issues. Please use the following number to contact the Navistar Product Support Center:

1-800-336-4500 option 3 then option 5
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